Slow Green progress bar in File Explorer - possible solution

I've had a problem with File Explorer since upgrading to Windows 10, where I get a green progress bar that crawls along slowly, delaying the results of folder display such as the Download and Documents folders. It could take up to a minute before the folders would display.

I tried many different things as possible solutions that I'd found when searching the web:

  1. SFC
  2. DISM
  3. various options in File Explorer

Nothing worked for me.

I then thought perhaps there's a problem with the indexing. I was about to rebuild the index under the control panel\Indexing\Advanced options, but by chance went into the Modify option which looks at indexed locations.

Here I noticed there were pointers to my D: drive to a series of folders which are not there any more. They appeared to be from an old user profile, with a comment beside them saying 'Unavailable'. I unticked these, clicked OK to save the changes, then restarted File Exlorer and found that I no longer get the slow green progress bar when I go into my Downloads and Documents folders.

I had upgraded to Windows 10 Pro x64 from Windows 8.1. I don't recall if I had this problem with Windows 8.1, but I think I probably did. Also, I used to re-direct my Documents and other personal folders to D\:username, but now I redirect them to D:\Users\username, and think somehow the old location was remembered by Search.

It worked for me. Hope it works for you.

 

Discussion Info


Last updated April 18, 2019 Views 37,753 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Thanks for the post. You might as well add your findings in this thread.

window 10 file explorer running slow. it takes years to fully load a - Microsoft Community :

http://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/window-10-file-explorer-running-slow-it-takes/deecd6b3-4e5f-49e2-b749-4f33f72eedb7?page=4

(that thread already had 11290 views.)

ex-MVP (2003-2012) (Windows Client)

Posted.

Thanks.

this is not the same issue. it not that explorer is not opening. It's opening fine, it just displays that bloody progress bar, 

I tried this a few minutes ago on my PC, it was doing the green progress bar every time I opened my downloads folder. So far no more progress bar. I hope it helps.

https://www.howtogeek.com/246087/how-to-speed-up-a-windows-folder-that-loads-very-slowly/

My Downloads folder was taking ages to load, even though I have deleted just about everything.

Decided to try changing Properties, right click on the Download folder, select Properties/Personalise. I just changed the "Optimise this file for" from videos to documents and now Downloads appears instantly.

Hope this helps!

My Downloads folder was taking ages to load, even though I have deleted just about everything.

Decided to try changing Properties, right click on the Download folder, select Properties/Personalise. I just changed the "Optimise this file for" from videos to documents and now Downloads appears instantly.

Hope this helps!

Tried it---except on mine it's Properties/Customize and you choose "Optimize this file for"---worked like a charm!

To clarify, left click the folder then 1. right click, 2. choose "properties", 3. click on "Customize" tab, 4. in combo box change (from "Pictures" in this instance) to "General items".  This preempts the green progress bar in Windows 10 File Explorer.

I see a lot of people using the solution of changing the properties on a media folder to behave as a regular file folder and that does seem to fix the problem, but...

I've had same media files on other's versions of Windows and this doesn't happen.

As I have mentioned in other posts, something is broken and it doesn't appear anyone is fixing it.

Rather there are a number of interesting workarounds to the "Slow Green Progress Bar".

Does anyone actually have any idea what is causing this nonsense?


Had this problem on a couple of PC's. What worked for me was hiding the Status Bar in explorer.

Control Panel\Appearance and Personalization\File Explorer Options
Under the View tab, scroll down and uncheck "Show status bar".

Thank you MTCSLtd,

I was recently given a Win 8 Pro PC by a friend who had cleaned it up leaving only Windows, Office 2007 and Sophos security.

File Manager was behaving infuriatingly and stopping me doing work.

After several modifications following advice forums this is the one that has done it.

Going into Control Panel\Indexing\Advanced options and then the Modify option showed that there were numerous, now non-existent indexing locations used previously by my friend.

I unticked these and chose the new location and all is well, including instant loading of thumbnails.

Thanks hugely.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.