Missing api-ms-win-core DLLs


I bought a laptop with Windows 8.1 and upgraded to Windows 10. It's a 64-bit system with an AMD processor. I'm trying to use py2exe to turn a Python script into a standalone executeable but I have missing DLLs. The list of DLLs is:

- api-ms-win-core-libraryloader-l1-2-1.dll
- api-ms-win-core-atoms-l1-1-0.dll
- api-ms-win-core-winrt-error-l1-1-1.dll
- api-ms-win-core-sidebyside-l1-1-0.dll
- api-ms-win-core-localization-obsolete-l1-3-0.dll
- api-ms-win-core-heap-l1-2-0.dll
- api-ms-win-core-heap-l2-1-0.dll
- api-ms-win-core-delayload-l1-1-1.dll
- api-ms-win-core-libraryloader-l1-2-0.dll
- api-ms-win-core-rtlsupport-l1-2-0.dll
- api-ms-win-core-shlwapi-obsolete-l1-2-0.dll
- api-ms-win-security-base-l1-2-0.dll

I do not know where to find these DLLs. I have installed the following in an attempt to resolve this but it has not worked:

- Visual C++ Redistributables (x86 and x64 - 2008, 2010, 2012, 2013 and 2015)

- Visual Studio 2010 Express

- Visual Studio 2010 Express Prerequisites x64

- Microsoft Windows SDK for Windows 7 (7.1)

Also Microsoft .NET Framework 4 Multi-Targeting Pack is listed in my Programs and Features list but I am unable to install ANY version of .NET Framework after 4. For example, when I try to install NEW Framework v4.6 the installer blocks and says I already have a newer version of .NET Framework installed. But when I tried to install Windows SDK for Windows 7 the installer told me I had a pre-release version of .NET Framework 4 (which I don't remember installing).

Where can I obtain the missing DLLs from?


Issue raised and answered at https://social.msdn.microsoft.com/Forums/en-US/a28331ae-19a3-4a34-b3ba-1e8fd4430375/missing-apimswincore-dlls

TLDR; They're part of architectural changes to Windows to support multiple devices and system architectures. They shouldn't be used or linked to directly and should not themselves be distributed. Rather apps and programs should make use of MinCore.lib or MinCore_Downlevel.lib.

In my particular case I excluded those DLLs from py2exe's process (using py2exe's exclude_dll option) and the resulting exe generated a missing DLL error on some systems but still ran fine.

339 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated June 17, 2021 Views 152,377 Applies to: