How to fix error message "Class not registered" in Windows 10 when opening pictures/photos

I have just upgraded to Windows 10. I keep getting the message Class not registered when I try to open pictures / photos. I don't want to lose them by playing about with the computer. Any ideas?

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Christopher,

I suggest you to run the system file checker scan and check if it helps.

System File Checker is a utility in Windows that allows users to scan for corruptions in Windows system files and restore corrupted files.

You can follow the steps in the following article:
http://answers.microsoft.com/en-us/windows/wiki/windows_other-system/system-file-check-sfc-scan-and-repair-system-files/bc609315-da1f-4775-812c-695b60477a93 
 

 

Please update us with the status. We will be glad to assist you.

K.Z. Sharief Khan
Ex-Microsoft Forum Moderator

33 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I solved this problem eventually.......   Start button>All apps>Windows system>Default programs.

You will see two "Default programs" ; use either, though the second (bearing the settings icon) is idiot proof.

The first button allows you to set a range of defaults within Windows 10.

Best of luck!

1548 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I solved this problem eventually.......   Start button>All apps>Windows system>Default programs.

You will see two "Default programs" ; use either, though the second (bearing the settings icon) is idiot proof.

The first button allows you to set a range of defaults within Windows 10.

Best of luck!

Steps:

Click on Windows icon bottom left in tool bar 

Select All apps

Scroll down and Click on "Windows System" drop down menu

Click on "Default Programs" with the settings icon

Change default program for photo viewer from TWINUI to Windows Photo Viewer or alternative

If this fails try my other reply which I found to work since windows would not let me change the default photo viewer via this method.

73 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have just upgraded to Windows 10. I keep getting the message Class not registered when I try to open pictures / photos. I don't want to lose them by playing about with the computer. Any ideas?

The most likely reason why this error has occurred is because Windows changed the default photo viewer to TWINUI, because it supposedly works better with PNG images. If you cannot change the default photo viewer back to Windows Photo Viewer from the All Apps menu, then try this:

Open File Explorer

Go into the Pictures Folder 

RIght Click a .png image file

Select Open With>

Click on "Choose another app"

Select Windows Photo Viewer

Check the box "Always use this app to open .png files"

Click OK

Now try clicking on other files. If the same error is occurring for other file types repeat the same method by clicking on a file of that type, such as JPEG or for video files. This error may occur with video files as well because TWINUI has replaced other default programs. You will see which default programs it has replaced by accessing Windows System Default Programs (settings icon) from the All Apps menu under the windows icon on the tool bar.

69 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I don't have an "Always use this app to open .png files" check box. Any other suggestions?

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Right click on the file or picture file, or video file and then click on Properties, then under the General tab about the second line down you should see “Opens with:” and to the right of that is the change button, click on that and change from “Twinui” to “Window Photo Viewer” or some other photo viewer. Do the same thing for video files, but change to something like “Windows Media Player” instead of “Twinui” or your preferred video player. This worked for me!

38 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

The problem I'm having is that Photo is the default on my system and I'm still getting the error.  I've tried all of the steps here and nothing seems to work for me.  Photo worked fine 2 days ago.  Nothing on the system's changed (that I'm aware of).  No programs added or changed by me.

26 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

The problem I'm having is that Photo is the default on my system and I'm still getting the error.  I've tried all of the steps here and nothing seems to work for me. 

It's the Photos app that's causing the error when starting. Reinstalling it solves the problem for most users. Check out 

How to Reinstall the Photos App in Windows 10?.

ex-MVP (2003-2012) (Windows Client)

13 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This also did not work.  The first process resulted in the following (SnipIt file) 

The second process was a 2 step one.  The first PackageFullName was not what you have in the blog.  I changed the name to what the result was from my computer and entered that instead.  Same result.  Next SnipIt file...

So now what?

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Reinstalling ALL packages (including Photos) might be worth a try. Check out:

http://answers.microsoft.com/en-us/windows/forum/windows_10-performance/taskbar-glitching-windows-10/ed33aef3-8aaa-4a2d-bea3-5340cc25101c

(Ignore the title)

ex-MVP (2003-2012) (Windows Client)

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated November 30, 2020 Views 181,028 Applies to: