How do you remove write-protection on a folder?

Hello,

Usually, after I scan a document, I am able to save it in a folder. However, after upgrading to Windows 10, I received a message that said the "location you are trying to save the file in is write protected. Please remove write-protected or use another disk to save." I've been trying to go to the "Properties" setting and un-check the "Read-only" box but I still cannot save my file in the folder that I want. The "write protection" message keeps popping up. Please guide me in how to remove the "write-protection" of the folder.

Thank you

|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Thank you for posting the query on Microsoft Community

Please refer the article and check if it helps.

File and Folder Permissions

https://msdn.microsoft.com/en-us/library/bb727008.aspx

Hope this helps. Please reply if you need further assistance.

Thank you.

58 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I think this is by design, and may have started in Windows 8.

I had the same problem.  The easy solution is to just save the file where it wants you to (documents for example).

Then - you can use file explorer to move it where you want, and it will prompt you to provide administrator privileges to move the file.

I know that's a work-around but it is a solution.  I haven't explored changing folder permissions yet to turn this off.  I think the idea behind it is to help protect the OS from apps saving things that could damage system files.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Maybe in Windows 10 it is a little more complicated than the old article suggests. Win 10 sets the document folder itself (along with pictures and so on) to write protect. It can be changed with administrator rights, but it will immediately revert to write protect. That means that not even from Word you can save a new document in the Document folder.

So - Users Document Folder is write protected even from both its owner and any administrator. Doesnt seem too smart...

13 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,

First of all, I apologies for the delay in response.

I understand your inconvenience. We are here to assist you.

We would like to know if you are still facing an issue with Windows 10. If yes, please do let us know. We will be glad to assist you in resolving the issue.

Thank you.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Yes, is still a problem in Windows 10. How is it possible that write-protection is not removable even as Administrator?

9 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Agree with RicardoMerino, Why not removable as Administrator?

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I am having this problem today: Working in an excel document, I run a macro that is supposed to write a simple file to the same folder where the excel document resides. I use this for accounting, and it has worked for a few years, last time a few days ago. Today I made a copy of the excel document in a different folder (new accounting year, new folder). When running the macro, it said access denied. The path is of the form //host/Users/Public/Documents/Year-2015, where "host" is a different computer from the one I am working at.

Investigating, I opened the File explorer, opened the /host/Users/Public/Documents folder, and clicked on the Properties of Year-2015. The Permissions tab said "All permissions" for user "Everybody". (Actually I have a Norwegian user interface, so I may possibly translate some of the keywords incorrectly.) But then on the first, or "General" tab, there is a "write protected" checkbox, which is checked. I click on it, and the checkmark goes away, but when I click OK, there is an error message. (Can't remember, possibly related to Administrator permissions. The user id has local administrator privileges.)

Before trying to remove the checkmark, I opened a Cygwin console, connected to the "host" using SSH, and issued an ATTRIB command on the directory (folder) "Year-2015". No attributes were set.

I then went downstairs to the computer actually hosting the folder. Same procedure, nearly the same result. The check mark was there, and went away. Clicking OK to close the dialog produced no error message. But when I opened the Properties dialog again, the check mark was there again.

I will now reboot the computer to see if it helps. So long.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Rebooting did not change the "write protected" check mark.

However, I found that the there was already a file in said folder with the name I wanted to create, and that file has "NUL SID" at the top of the list of users with permissions, with no permissions, and the "Everybody" group has only Read and Read and Execute permissions. So that explains the problem I had with running said macro. 

The question that remains is why under windows 10 there is this "Write protected" check mark in the General tab of every folder I have looked at now. And what does this check mark mean, since it apparently does not prevent me from creating files or renaming them, and it does not otherwise prevent me from writing to files either.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This goes back as far as Vista. They just don't care.

However, on my side the issue doesn't seem to have any consequences. Folders that are marked as write-protected can still be written to.

But if you're debugging a script, for instance, it may look as if the issue at hand is causing the error.  

In the process of expanding permissions I probably weakened my computer's security, and I can't remember everything I did. That's what seemingly irrelevant Windows errors can do to you. Attention to detail is not everyone's forte (or interest), so it seems. Which, for a top-tier developer, is a shame, if you ask me.

End of rant!

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Still a problem!  I have done everything I know and still nothing.  These files are my work and my financials.  My business will be at a stand still of sorts if this can't be resolved. Any real solution -- even if it means copying the files to another resting place is fine.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated May 14, 2021 Views 67,904 Applies to: