Copy speed very slow in windows 10

I have recently upgraded my laptop from windows 7 to windows 10. After upgrading, I am facing problems in Windows 10 regarding copying files & folders.

When I try to copy files from laptop to my external drives, the speed fluctuates frequently. In case of External hard disk, the copy speed reaches to 8-10 MB/s and instantly drops down to 0 byte/s. Also in case of pen drive, the copy speed reaches to 4-5 MB/s and instantly drops down to 0 byte/s. This fluctuation makes the copy operation very very slow.

What's the problem?

Can someone provide me the solution for this?

Thanks in advance.

|
Answer
Answer

Hi Sunil,

Thank you for posting the query on Microsoft Community. I am glad to assist you on this.

I would suggest you to follow these methods to fix the file transfer issue and check.

Method 1:     

Run System Maintenance Troubleshooter

Follow these steps to run System Maintenance troubleshooter.

a.      Press Windows key + W and type troubleshooting.

b.      Select troubleshooting.

c.       Select View all on the top left corner.

d.      Run System Maintenance trouble shooter.

Method 2:

I would suggest you to turn off the Auto tuning feature and then try to transfer the files.

Follow these steps to turn off Auto-tuning:

a.      Press Windows key + X and select Command Prompt(Admin).

b.      Type “netsh int tcp set global autotuninglevel=disabled” and press Enter.

c.       Now try to transfer the files and check the data transfer speed.

d.      Again go to Command Prompt(Admin) and type “netsh int tcp set global autotuninglevel=normal” and press Enter.

e.      This will turn on the Auto tuning again.

Method 3:

I would suggest you to disable Remote Differential Compression and check. Remote Differential Compression (RDC) allows data to be synchronized with a remote source using compression techniques to minimize the amount of data sent across the network. RDC is different from patching-oriented differencing mechanisms, such as Binary Delta Compression (BDC), that are designed to operate only on known versions of a single file.

Follow these steps to do so:

a.      Press Windows key + W and type “turn windows features on”.

b.      Select Turn Windows features on or off.

c.       Uncheck the box for Remote Differential Compression and click Ok.

d.      Restart the computer and then try transferring the files.

Hope this helps. If you face any issues with Windows, do get back to us. We will be happy to assist you.

1028 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated May 11, 2021 Views 263,501 Applies to: