Language Hotkeys removed by itself (Windows 10)

This problem used to happen in previous versions of Windows and users had found workarounds for it (http://answers.microsoft.com/en-us/windows/forum/windows_8-desktop/custom-hotkeys-to-change-input-language-disappear/66d1d89d-e5dc-41e1-a8b3-48d596ab8e11). However those soloutions do not work for Windows 10.

I have 3 keyboards and I have defined Ctrl+1, Ctrl+2 and Ctrl+3 hotkeys for them. The problem is that either all of the hotkeys or the first one is removed regularly (when windows goes to sleep or lock screen all the hot-keys are removed).

This makes me crazy when I am in hurry to get something done (and the problem kicks in).

Please do not suggest blind generic (mostly nonsense) solutions like running sfc etc. I have done most of them without luck.

Thanks.

 

Question Info


Last updated August 18, 2019 Views 399 Applies to:

Hi,

Thank you for posting in Community, I understand your concern and we will try our best to help you resolve the issue.

The issue that you are facing can be due to various reasons.

To narrow down the issue, I would like to suggest that re assign the hotkeys for the languages and check if the issue re appears. Also I would suggest that you log into the computer from another User Account and check if the same issue persist.

Hope this information helps. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Arul, thank you for your response.

I tried different hotkeys (Ctrl+1 ... Ctrl+3), (Ctrl+Shift+1 ... Ctrl+Shift+3) and (Alt+Shift+1 ... Alt+Shift+3).

All of them get removed as soon as the windows goes to sleep (automatically or manually) or even locked.

Btw. sfc/scannow shows finds no error and my windows is build 10586.

Thanks.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I finally found the solution and I am posting, in case someone else has the problem.

1- Define your hot-keys.

2- Search and find the "region" settings palette and go to administrative tab.

Now go to "Copy Settings" section.

Select both tick boxes below the window and press ok.

In my case this applied the settings in a way that they are no more removed.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thank you for sharing your solution. This will help the other Community members who are facing similar issue.

For any query related to Windows Operating System, feel free to post on Microsoft Community. We will be happy to assist you.

Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.