how to remove keyboard layout on Windows 10?

Original Title: how to permanent remove keyboard layout?

I am French, living in Germany, but prefer to use Windows in English US. Tired of different keyboard layouts, I also have now only keyboard with US layout. So I removed French and German keyboard layouts, but Windows somehow kept them and KEEP switching back to a German layout anytime I come back from the lock screen.

I disabled the quick layout shortcut, I don't want any, just the US layout.

So just US layout for my physical keyboard on my desktop (USB) and tablet (Bluetooth), both having a full up to date Windows 10 10586.218 (x64 on desktop, 32bits on tablet).

On the same live account, I am also using a Windows 10 Mobile device (Nokia 730) on which I only use touch keyboard and thus need all 3 layouts (French, English, German). I hope my account settings are not mixing up with the windows settings!!

Here a screenshot on my tablet: for each of the 3 languages, only the US keyboard layout is configured, but on the langage list, I also get the French and German keyboards.

How can I get rid of them for good?? This is particularly annoying since the German keyboard is set back as default at any windows lock screen!!

Answer
Answer

Hi Eric,

 

We regret the inconvenience caused.

 

The above issue might occur due to the following reasons:

  1. Country & Region settings not enabling you to delete the keyboard language set on the PC.
  2. Not choosing appropriate default keyboard layout.

 

Before we assist you further, I would like to ask you a few questions:

  1. Did you try removing the keyboard layouts from Settings page?
  2. If yes, does the issue persists even after removing the keyboard layout?

 

By removing the Keyboard layout from system Settings page, the language will be removed from the PC. However, if needed, you can download the same from system Settings page and check if the changes made are effective.

 

You can remove the keyboard layout either from system Settings page or Control panel. Follow either of the steps below to remove the keyboard layout and check if the issue is resolved.

 

Step 1: System Settings window.

 

  1. Press Windows logo + I keys on the keyboard to open Settings page.
  2. Click on Time & language from the options and select Region & language from the left side panel of the window.
  3. Click on the keyboard language you want to remove under Languages and click on Remove.
  4. Close the window and check if the changes are effective.

 

Step 2: Control panel.

 

  1. Press Windows logo + X keys on the keyboard and click on Control panel from the context menu.
  2. Click on View by option located at the top right corner of the window and select Large icons from the dropdown bar.
  3. From the panel, click on Language.
  4. Under Change your language preferences click on the keyboard layout to remove and click on the Remove button which will now be available to use.
  5. Close the window and check if the changes are effective.

 

Write to us with the status of the issue on the keyboard layout language removed from the PC for further assistance. Your reply is most important for us to ensure we assist you accordingly.

 

Thank you.

 

 

89 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated November 28, 2020 Views 172,312 Applies to: