Windows 10 mail app: Your iCloud settings are out-of-date

Hello 

I'm really hoping some smart soul out there has a solution to this head scratcher. I'm using a brand new MS Surface Book, Windows 10. On the Mail app I can't get my iCloud email to work. I get either the error above after attempting to sync, or this:

"We're having a problem downloading messages. Make sure you have a connection and your account info is correct, and then try again. Error code: 0x801901f5"

My ID and password are correct. I've spent 2 days removing and adding my email, reinstalling the app (used PowerShell), Googling for help and checking config settings, access via Windows Firewall (I'm not an AVG or Windows Defender user) and making sure my privacy settings allow access to Mail and Calendar.

No joy. Does anyone have a fix?

 

Question Info


Last updated April 18, 2019 Views 87,635 Applies to:
Answer

Fixed it! Here's what worked for me.

My iCloud email is protected with Apple's two step verification, so I needed an 'app-specific password' to sign into an app that's not provided by Apple, like Windows Mail which doesn't support entering verification codes.

It was pretty simple in the end (took 4 days of hunting down the answer though!)

Here's the steps (I did this via my MS Surface Book laptop):

  • sign into Apple ID with your iCloud email and password: https://appleid.apple.com/account/manage
  • if you're a two step verification user, your device (for me, my iPhone) will give you a verification code to enter after you put in your iCloud email password
  • in the 'Security' section, hit 'Edit'
  • in the 'App-Specific Passwords' section, hit 'Generate Password...'
  • enter a label for this password (I typed 'Windows 10 mail app')
  • hit 'Create'
  • an app-specific password will be created for you, in this format (case sensitive) tmah-jdbq-rdby-gdes
  • copy the password and hit 'Done'
  • now open up Windows Mail > settings (cog icon) > manage accounts > select your iCloud account and enter your app-specific password then 'Save' - do not enter your iCloud email password, you just need to input the app-specific password

Your iCloud email should now start to appear. Though I spent days fiddling around with the config settings, it seems Windows Mail pre-set config is correct, so you shouldn't need to change the incoming or outgoing email server settings:

Incoming email server: imap.mail.me.com:993:1

Outgoing (SMTP) email server: smtp.mail.me.com:587:1

I hope this helps someone. A word of warning though. If you change your primary Apple ID password, all your app-specific passwords will be automatically revoked and you'll need to generate a new one for any apps you want to keep using.

2350 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.