Cannot Install KB2957689 (Error Code 800F0922)

Hello,

I am attempting to apply the latest round of updates for Windows 8.1. The system is an ASUS P1801 All-in-One with i7-3770K processor, a Samsung 840 Series 512GB SSD and an nVidia 730M video card with 2GB of video RAM. FWIW, the system experienced some problems with updates back in April that required a lengthy intervention from Microsoft (ticket number available upon request.) Those problems seemed to be rooted in a general problem with core component corruption within Windows. That corruption had damaged the administrative account I was using and repair of that as well as a general repair of Windows itself fixed the issue with those updates.

As to the problem encountered earlier today - it seems that all the updates finally were able to be installed EXCEPT for:

Cumulative Security Update for Internet Explorer 11 for Windows 8.1 for x64-based Systems (KB2957689)

Installation date: ‎6/‎10/‎2014 2:00 PM

Installation status: Failed

Error details: Code 800F0922

Update type: Important

Installing the other updates (approximately 20 or 21 including one optional - the others were all listed as "Important") had to be in a series of steps. When I tried to install all at once it failed after installing 13 Important updates. I then installed the remaining updates by ones and twos until they all installed except for the above noted Internet Explorer 11 update.

I have read a bit on the error code (800F0922) and some seem to be writing that re-installing Windows fixed the issue but first, I don't want to have to do that unless there is no option, and second, this approach was in reference to another KB and not the one listed above. I also read the MS14-035 document that concerns the installation of KB2857689 itself and it stated that update KB2919355 or KB2929347 must be present in order to install KB2957689 successfully. I have confirmed that KB2919355 has been successfully installed but still no joy in stalling KB2957689.

Any thoughts on the above issue and how to approach it?

Thanks in advance,

Paul

 

Question Info


Last updated January 30, 2019 Views 3,595 Applies to:
Answer
Answer

I'm sorry to chime in here... since the instructions by Srimadhwa will certainly help in most of the cases.

But I was having the exact same issue and it was caused by my HIPS program (Online Armor).

Following the provided methods above didn't really help here since Online Armor didn't really allow itself to be "fully" disabled (for obvious reasons), so temporary uninstalling Online Armor was the only option here. And after uninstalling, this KB installed fine this time.

So, *just in case*, if you have Online Armor installed - that might be the cause.

I already reported this to the Online Armor support people.

Just my 2cts :-)

MS MVP Consumer Security since 2006

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.