Q: All Modern apps fail to start after Windows 8.1 upgrade This thread is locked from future replies

All Modern apps show an "X" in their bottom right corner.

Here is some additional information:

I Installed via the Windows Store today
I upgraded from Windows 8
Store won't open. It shows the splash screen, then a solid color screen. Nothing else happens. If I click anywhere, it goes back to the start screen.
I also can't open "Settings" found by moving the mouse in top right corner, Settings, Change PC Settings. Does same thing as store. Splash screen and nothing happens. Can click back to start screen.

For clarity, I can't get any other Modern app to run either. If I try to run any other Modern app (Calendar, Food and Drink, etc), I get the following error message:

This app can't open. There's a problem with <app name>. Contact your system administrator about repairing or reinstalling it.

If I run wsreset.exe I get the following error, it does the same thing I mentioned the store doing before. When I get back to the desktop, there is a popup that says:

The app didn't start.

Elsewhere, I've seen people suggesting that I run this command:

powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

When I do, I get this error:

Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could
not be registered.
error 0x8007064A: Cannot register the request because the following error was
encountered while initializing the windows.repositoryExtension extension: The
configuration data for this product is corrupt. Contact your support personnel.
NOTE: For additional information, look for [ActivityId]
d62b9028-cd30-0000-4e93-2bd630cdce01 in the Event Log or use the command line
Get-AppxLog -ActivityID d62b9028-cd30-0000-4e93-2bd630cdce01
At line:1 char:1
+ Add-AppxPackage -DisableDevelopmentMode -Register
$Env:SystemRoot\WinStore\AppxM ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : WriteError: (C:\WINDOWS\WinStore\AppxManifest.xm
   l:String) [Add-AppxPackage], IOException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageMa

I have also run the apps.diagcab tool multiple times. It tells me my display adapter drivers might need to be updated (they don't) and and also tells met that it did a "Check for missing or corrupt files" which it says it detected every time. I have run it and rebooted multiple times. I'm not running any anti-virus other than Windows Defender. I had Stardock's ModernMix running in Window 8 before the upgrade. I thought it might be causing an issue so I uninstalled it. Issue still existed. I haven't done anything else to the system other than running some Windows Updates.

Any/all help is appreciated. Thanks.



At long last I found a fix. The information can be found in a post over in the Technet forums, but I'll copy it here for anybody else.

Quoted message below:

Guys, i've FINALLY found an answer to how to get this to work again, (courtesy of andy562)!  Andrés this may work for you too. 

The following finally fixed all issues for me (Store and all apps broken with black X, can't access PC Settings):

A.) Fixing the app store:

  1. Open registry editor typing regedit.exe from a command line.
  2. Browse to the registry key at HKEY_CURRENT_USER\Software\Classes\Local Settings\software\microsoft\windows\currentversion\appmodel\repository\packages.
  3. Right click on the “packages” key and bring up the “Permissions” tab.
  4. Click the “Advanced” button located at the bottom right corner.
  5. Check to see the account name that shows up as the “Owner” (this is the first line of text on the “advanced security settings” dialog for the “packages” key). It should say “SYSTEM”.  (For me this showed the built-in local Administrators group)
  6. If it is any other account, click on the “Change” button next to it.
  7. Type SYSTEM in the “select user” dialog. If “Multiple Names Found” window comes up, select the row for “SYSTEM”.
  8. Click OK to the dialogs and close them all.
  9. Run from admin command prompt:     Powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

B.) Fixing all modern apps:

  1. Run from admin PowerShell:

((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications") | Get-ItemProperty).Path | Add-AppxPackage -Register -DisableDevelopmentMode

    * When I ran this the black X persisted until after the next step and reboot.  But trying to start an app gives me a new message and a link to the store.

C.) Fixing 3rd party apps:

  1. Delete the regkey:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\[UserSID] 

          You can find your SID by going to an elevated command prompt and typing

                        wmic useraccount get name,sid

D.) Restart.  After a reboot the apps still showed the black X for a minute or so, but it soon cleared up on its own and all apps seemed to be working again.  I was also able to update the apps from the app store once signing in with a Microsoft account.  Finally, I am again able to get into PC Settings.

Did this solve your problem?

Sorry this didn't help.

13 people were helped by this reply



There is a very simple solution. just have a look.

Did this solve your problem?

Sorry this didn't help.

Question Info

Views: 99,970 Last updated: February 21, 2018 Applies to: