KB2918614 breaks Windows Installer Service

I didnt know where best to post a bug report about KB2918614.

This is for Windows 8.1 Pro

It appears on August 13 I received KB2918614 and immediately after I began having trouble with certain MSI installations, especially those that required any version of Visual C++ Redistributable to be installed.

Now, of course I have most of those already installed, but the install process of many programs runs those redistributables before the actual install runs.  It would always give me the error of "key not valid for use in specified state" and exit with a 1603 event.

I didnt know what caused the problem at the time and went through many troubleshooting steps including sfc/scannow, registry modifications (which have all been switched back to their original values), and attempts at re-installing the Windows Installer Service for Windows 8.1 (5.0) which apparently does not have its own redistributable install file.

Eventually I determined that I received a large number of updates on 8/13, so I removed them all.  This immediately fixed my problem.

As I didnt know if that was a fluke and I didnt know which specific update caused the problem, on reboot they all re-installed.

The problem returned as soon as I started back into windows.

I went through each of the knowledgebase articles and located KB2918614 as being the only one that modifies the MSI Windows installer service files.

I have now removed and hidden this update.

I wanted to notify Microsoft of this issue but did not know the best method to do so, so I am posting it in the Microsoft community in the event another user has the same problem as I did in order to work around it.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

suffering from this on Windows 7 Professional SP1.

Installs are "looping".

I am using Windows 7 Ultimate wit SP1.

After installing the update KB2918614, i had the same problem. I couldn't install or deinstall 64bit applications (error code 1719).

After removing the update, i didn't have any problems!

I'd like to endorse this bug report. Our products get installed using InstallShield. Since 14th Aug 2014 we've had 3 reports from customers who can't run our installer any more. They get the same error message as reported above (key not valid for use in specific state). All three customers were using Windows 7, 64-bit.. They removed update KB2918614 and the installer magically started working again.

Before reporting here, I tried to reproduce the problem locally but I couldn't reproduce it either on 32-bit or 64-bit Windows 7 (in both cases, the suspect update - KB2918614 - had been applied but on my machines, our installer worked as expected). So in other words, the bug seems to affect some Windows users but not others. I appreciate that this will make it difficult to track down - but it's a serious bug and needs urgent investigation!

Windows 8.1 enterprise (64-bit) user here. Same experience. Installer refuses install anything, always quitting with that key invalid for use in specified state error message. Uninstalled this update after a google search found this thread and all installs work perfectly. (Until windows update reinstalls this update again...)

I am seeing this also with just 1 machine so far. The error message in the logs reads.

 SECREPAIR: A general error running CryptAcquireContext
MSI (s) (3C:10) [09:27:13:873]: SECREPAIR: Crypt Provider not initialized. Error:-2146893813

When I uninstall the Patch the applications installs without a problem.

Which log is that in?

 Error:-2146893813

Converting to Hex would probably provide a better search result:

http://social.technet.microsoft.com/wiki/contents/articles/15260.windows-update-agent-error-codes.aspx

(BING search for
    (0x8009000B OR 8009000B) "Installer service"
)

<quote>
0x8009000B -2146893813 NTE_Bad_Key_State

</quote>

Hardly more informative!

The good news may be that this symptom may be fixable.  The bad I don't know how to apply this information to your case:

http://social.technet.microsoft.com/Forums/sqlserver/en-US/d7aba2a0-e81e-48ce-b0d5-c181251de74c/key-not-valid-for-use-in-specified-state-with-an-exception?forum=sqlreportingservices

(BING search for

    (0x8009000B OR 8009000B) NTE_Bad_Key_State  site:microsoft.com (MVP OR MSFT)
)

FYI

Robert Aldwinckle
---

My system is Windows 7 Home Premium 32-Bit.

I have exactly the same problems with installing *.msi installation files after updating windows.

So I uninstalled the update KB2918614 and the Windows Installer works fine again.

Now I have to handle my updates manually to prevent the KB2918614 update.

I hope Microsoft will fix this problem.

I've also encountered this error on Windows 7 SP1 and Windows 8.1 Pro

For me the error appeared when attempting to install Adobe Shockwave 12.1.3.153 via MSI.

All the machines I tried the install on that had this patch installed failed, while a system that did not have that patch installed it without issue. After removing the patch from an affected system the install runs fine.

The EXE based installer for Shockwave did not display this issue.

I've set the update to Remove on my WSUS server, and intend to do the same at work once I verify the problem exists there as well.

What is the error you get when this happens and what behavior do you experience, e.g., won't install at all, fsios part way through? Does every computer fail with the same error? Have you tried running the update with a clean bout, do you get the same failure or a different one? It is curious why some many of the computers are failing 100% of the time but the update doesnt effect every pc elsewhere

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Discussion Info


Last updated October 4, 2020 Views 72,744 Applies to: