Weather Application

I am getting 50-60 of these error messages whenever I use the new weather app in Windows 8.1. I did not get these with windows 8.0.

Log Name:      System
Source:        Microsoft-Windows-DistributedCOM
Date:          10/18/2013 10:19:46 AM
Event ID:      10016
Task Category: None
Level:         Error
Keywords:      Classic
User:          BILLBYRNES-PC\Bill
Computer:      BillByrnes-PC
Description:
The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{C2F03A33-21F5-47FA-B4BB-156362A2F239}
 and APPID
{316CDED5-E4AE-4B15-9113-7055D84DCC97}
 to the user BillByrnes-PC\Bill SID (S-1-5-21-785223239-24766898-2466987873-1001) from address LocalHost (Using LRPC) running in the application container Microsoft.BingWeather_3.0.1.174_x64__8wekyb3d8bbwe SID (S-1-15-2-2040986369-264322980-3882385089-1970153872-3662121739-3363227934-2464603330). This security permission can be modified using the Component Services administrative tool.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
    <EventID Qualifiers="0">10016</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2013-10-18T15:19:46.861789500Z" />
    <EventRecordID>13403</EventRecordID>
    <Correlation />
    <Execution ProcessID="952" ThreadID="7272" />
    <Channel>System</Channel>
    <Computer>BillByrnes-PC</Computer>
    <Security UserID="S-1-5-21-785223239-24766898-2466987873-1001" />
  </System>
  <EventData>
    <Data Name="param1">machine-default</Data>
    <Data Name="param2">Local</Data>
    <Data Name="param3">Activation</Data>
    <Data Name="param4">{C2F03A33-21F5-47FA-B4BB-156362A2F239}</Data>
    <Data Name="param5">{316CDED5-E4AE-4B15-9113-7055D84DCC97}</Data>
    <Data Name="param6">BillByrnes-PC</Data>
    <Data Name="param7">Bill</Data>
    <Data Name="param8">S-1-5-21-785223239-24766898-2466987873-1001</Data>
    <Data Name="param9">LocalHost (Using LRPC)</Data>
    <Data Name="param10">Microsoft.BingWeather_3.0.1.174_x64__8wekyb3d8bbwe</Data>
    <Data Name="param11">S-1-15-2-2040986369-264322980-3882385089-1970153872-3662121739-3363227934-2464603330</Data>
  </EventData>
</Event>

Thanks for you help.

Bill Byrnes
 

Question Info


Last updated December 3, 2018 Views 96,710 Applies to:
Answer
Thank you very, very much for posting this! Much appreciated!

I've been trying to figure this out for a couple weeks and thought it was driver or bios issues. I was having the event log spam as well as the problem of hanging on shutdown.

This resolved both issues, but I did have to make some edits to your fix. I'll repeat your steps below with the edits in bold.

1. Open Regedit.
2. Go to HKEY_Classes_Root\CLSID\*CLSID*.
Note: *CLSID* stand for the ID that appears in your event viewer error. In your case, it's {C2F03A33-21F5-47FA-B4BB-156362A2F239}. 
3. Right click on it then select permission. 
4. Click Advance and change the owner to Administrators. Also click the box that will appear below the owner line.
5. Apply full control.
6. Close the tab then go to HKEY_LocalMachine\Software\Classes\AppID\*APPID*.
Note: *AppID* is the ID that appears in your event viewer. In your case it's {316CDED5-E4AE-4B15-9113-7055D84DCC97}.
7. Right click on it then select permission.
8. Click Advance and change the owner to Administrators.
9. Click the box that will appear below the owner line.
10. Click Apply and grant full control to Administrators.
11. Close all tabs and go to Administrative tool.
12. Open component services.
13. Click Computer, click my computer, then click DCOM.
14. Look for the corresponding service that appears on the error viewer.
Note: For this step, look for the one that appeared at the right panel of the RegEdit. For example, the AppID Registry (316CDED5-E4AE-4B15-9113-7055D84DCC97) contains the "Immersive Shell" Data with a (Default) as a name. Now look for "Immersive Shell".
15. Right click on it then click properties.
16. Click security tab then click Customize in the Launch and Activation permissions section. Click Edit. Click Add. Add Local Service. Then apply.
17. Tick the Local Activation box.

Line 4 you had the user Administrator added, not the group Administrators. After making this change my hang on shutdown was fixed. To fix the DCOM error, I had to add Local Service not System with activation permissions. 

Hope this helps.

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Hi

Not sure if this will fix your issue but I was able to fix mine.

1. Open Regedit.
2. Go to HKEY_Classes_Root\CLSID\*CLSID*.
Note: *CLSID* stand for the ID that appears in your event viewer error. In your case, it's {C2F03A33-21F5-47FA-B4BB-156362A2F239}.
3. Right click on it then select permission.
4. Click Advance and change the owner to administrator. Also click the box that will appear below the owner line.
5. Apply full control.
6. Close the tab then go to HKEY_LocalMachine\Software\Classes\AppID\*APPID*.
Note: *AppID* is the ID that appears in your event viewer. In your case it's {316CDED5-E4AE-4B15-9113-7055D84DCC97}.
7. Right click on it then select permission.
8. Click Advance and change the owner to administrators.
9. Click the box that will appear below the owner line.
10. Click Apply and grant full control to Administrators.
11. Close all tabs and go to Administrative tool.
12. Open component services.
13. Click Computer, click my computer, then click DCOM.
14. Look for the corresponding service that appears on the error viewer.
Note: For this step, look for the one that appeared at the right panel of the RegEdit. For example, the AppID Registry (316CDED5-E4AE-4B15-9113-7055D84DCC97) contains the "Immersive Shell" Data with a (Default) as a name. Now look for "Immersive Shell".
15. Right click on it then click properties.
16. Click security tab then click Add User. Add SYSTEM then apply.
17. Tick the Activate local box.

Restart.


Hope that helps.


EDIT: I edited the step number 14 for it to be clearer. I am glad that I was able to help out.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.