Q: Can't enable or install .NET Framework 3.5 in Windows 8.1 PRO 64-bit This thread is locked from future replies

I continually receive the message in a dialogue that

"Windows couldn't complete the requested changes.

The system cannot find the file specified.

Error code: 0x80070002"

I have not been able to find my way around it.  Running on a 4770K system with fresh install, only user, and with Admin privileges, and usually running Command and many other programs as Administrator.

Can't turn 3.5 on through Control Panel "Turn Windows features on or off", although .NET Framework 4.5 Advanced Services IS enabled.

No success either, using installers provided with programs that require that version of .NET.  As they do require it, I am hoping to get this resolved.

No success with DISM method of scanhealth & restorehealth, although these run OK.

No success with DISM method to install from distribuion CD, mounted ISO, or folder Sources\sxs folder copied to hard drive (including using /LimitAccess switch).

I haven't been able to figure out from looking at the DISM and CBS logs what might be missing.

No success changing server or path in Administrative Templates, etc. regarding Windows Update, for installing components.

No success from .NET full download or stub from Microsoft website.

Microsoft's Windows Update fix-it tool doesn't come up with a solution, either, or point to the culprit with any useful detail.

I've tried to be reasonably methodical in working this out, but I still don't seem to be getting anywhere.


<Merged Duplicate (2) Threads>



Hi everyone,

I solved the problem .Just copy  the single  file from sxs folder of windows 10 dvd or iso to your local drive.

Extract this file using winrar.

Now run DISM command wih administrator privilege  with extracted folder as a source path


dism / online /Enable-Feature /featurename:NetFx3 /All /Source:D:Sources\sxs

Did this solve your problem?

Sorry this didn't help.

6 people were helped by this reply

Question Info

Views: 102,049 Last updated: March 16, 2018 Applies to: