WINDOWS 8 Update Searches forever (SOLVED)

I was aware that a lot of Windows 8 user that clean installed Windows 8 are facing issues with Windws Updates searching forever. Follow the steps:


Log onto the PC in safe mode
Right click Start and click Command Prompt (Run as Administrator), then type and enter on eachthe following:

net stop bits

net stop wuauserv

net stop appidsvc

net stop cryptsvc

Ren %systemroot%\SoftwareDistribution SoftwareDistribution.bak

Ren %systemroot%\system32\catroot2 catroot2.bak

Restart the PC

Disable Windows Automatic Update (Go into Control Panel, click System, click Windows Update, click Change Settings on left side, click the scroll down and click "Never check for updates" and click OK.)

Open command prompt in administrator mode again and type the following and hit enter after each.

net start bits

net start wuauserv

net start appidsvc

net start cryptsvc

Download and install these updates: KB3173424 and KB3172614 (Search the update with 32 or 64 bit of your PC as KB------ 64bit for example.) Install the KB3173424 first.

Reboot and check for updates. (May take up to 30 minutes depending on connection speed. Once updates are found, go to change settings and click "Download and install updates automatically".)

If anyone replies with a negative and/or drama about having problems other than Windows 8 update resolution, just note that you caused those problems on your side.

Please mark this solution as answered.

Just wanted to that following this advice (to the letter), my Windows Update kicked back into life.

Thank you

Anytime, please mark my solution as answer for everyone.
Anytime, please mark my solution as answer for everyone.
Thank you!!! I cannot begin to tell you how many pages of fixes I have been through, MS or otherwise. I spent days trying to get WU to work on my mom's old Windows 8.1 (granted, it hadn't been updated in 2 years, but still...) Hours and hours of searching and trying so many different solutions. I love the sites that say, "THIS WILL WORK, I GUARANTEE!" and it doesn't. Or it calls for changing a setting that does not exist. Then there are the MS KB pages with dead links. Or it says, "Sorry, if that didn't work you need to reinstall Windows." Like that's the go-to solution. And Lord knows how many error codes there are. It's hard to imagine that in 2017 there isn't a way that MS can truly diagnose and fix WU issues...not to mention how amazing it is that there are so many. There must be more questions/pages/solutions on this than just about anything.   

At any rate, your solution worked perfectly.

Now if I could only get WU working on an old W7 SP1 that hasn't been updated in 2 years...
For Windows 7 Updates, Insert the Windows 10 ISO disk / USB and let it check for updates. Once that is done, remove the disk / USB from PC and let it check for updates now. It may take no later than an hour. If it still searches, use the Windows Update troubleshooter by navigating to Control Panel, then System and Maintenance, then Troubleshoot. Link for troubleshooting update should be shown. If success, run windows update and boo ya.

Here's where I am after a little over two hours. I created a USB but the Asus A8N-SLI has a weird boot menu that does not list USB It does have Removable Devices but only floppy is listed. There are a few hard drive listings along with DVD and CD. I did a search and found lots of people with the same mobo who could not figure out how to boot from USB either. I tried a few options. At the same time, I made a bootable DVD from ISO. Then I tried that. Turns out, wouldn't you know, this machine has a faulty DVD drive that runs but isn't recognized. So the DVD option is out. Finally, by trial and error, I discovered that to boot from USB you actually have to set first boot to Hard Drive 1.26. It's listed under hard drives. Finally I was able to boot off the USB but all I get is the blue logo and it sits there. I did a number of searches and found a lot of people with the same issue. I waited awhile but I don't think it's doing anything. Is it possible the machine is just too old?

ASUS A8N-SLI mobo
AMD Athlon 4000+2.41 GHz
4 GB RAM500 GB HDD

It's an 8GB USB key. The current OS is Windows 7 Ultimate SP1 x64.

Any ideas? Thanks.

 

Hi, good news. It's fixed. Each time I ran the Update or the Troubleshooter I had a different error code, which made it really hard to stay on track -- I had to keep searching for new fixes. The last one I got this morning was a code that basically said "you've tried to update too much...try again later." I set it to automatically check and it just notified me with new updates and it worked.

Thanks for all the help! I learned a lot along the way, anyway.
You are welcome. Just remember sites that are not apart of Microsoft will falsify solution so don't guarantee that those will work.      
I also did a fresh install of windows 8 (all i ahev atm) the pro version in 64 but ... ive use dit for a few days and encountered a few problems jn games and stuff so just want to kepe everyhing uodated but having same issue and the yodates are take forever ... i inoutted the first 4 lines of code wihout a oroblem butbthe other ones ont hat step dont seen to work .. any help ?
Wait never mind guys i think ive solved it ... i went into where youd turn off automatic updates ... control oanel , system and security, wi dows update ... cliked on all updates available or somehig liem rhat and rhen just clicked install and now its just installing them (i hope... its kn #6 of 18)
 
 

Discussion Info


Last updated November 25, 2020 Views 39,860 Applies to: