Prevent Windows 8.1 Windows Update from downloading Windows 10 update over and over again.

I want to stop Windows 8.1 from downloading Windows 10 over and over again to my SSD (C:).

I wont install it, don't bug me EVER again.

The worst we CAN'T TURN OFF THAT IRRITATING GWX.EXE ICON. I had to uninstall and hide an update to block it.

Now, without this update I get the installer every time from Windows Update after I manually deleted it.

Folder name: Windows.~BT

What I want: NEVER BUG ME AGAIN AND FORGET DOWNLOADING THIS WHOLE W10 UPDATE FOLDER AGAIN!

I'll stay with 8.1, thanks!

Ps.: I'm not (extra) angry, just hating that we don't have ANY option to opt out of this.

What I did until now:

- Disabled the GWX update (hidden)

- Disabled the Windows 10 upgrade update (hidden)

- Removed the Windows.~BT folder (linux live cd)

Update: After I hide the "Upgrade to Windows 10 Pro" update, it activates itself again after some time (2-3 days maybe, havent check).

Service number: 1304928613

|

Hi Sandros,

Thank you for posting your query in Microsoft Community.

I really appreciate your efforts taken to resolve the issue. I understand that you have tried all the basic measures to resolve the issue. However, I would suggest you to try the following methods and check if the issue persists.

Method 1:Uninstall the Windows Update as follow:

Remove the Windows update KB 3035583

If the issue persists, follow method 2.

Method 2: Rename the GWXUXWorker.exe

Terminate the GWX.exe process using Task Manager. Moreover rename the GWXUXWorker.exe and GWX.exe to .old as suffix from directory location:-

Windows\System32\GWX, if getting any issues while renaming then give the system permission's to respective files and then try to rename it again. OR you can delete the entire directory folder.

If the issue persists, follow method 3.

Method 3:  Registry key to stop the notification :-

  1. Press Windows key + R on your keyboard to open the run dialog box.

  2. In the Open field, type regedit.

  3. Click OK.

  4. Click Yes on the User Account Control (if prompted).

  5. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Gwx

  6. Right click.

  7. Click Modify.

  8. In the Value data: field, dword:00000001.

  9. Click OK.

  10. Exit Registry Editor.

Important this method contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 

How to back up and restore the registry in Windows

Hope this information is helpful. If the issue still persists, please post back for further assistance, we'll be glad to assist you.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

It doesn't help. I don't have the GWX icon, but the "Get Windows 10 Pro" Update shows up after 1-2 days when I "hide" this update.
sandros.hu

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated February 20, 2018 Views 156 Applies to: