Question

Q: LaunchAnywhere Error: Windows error 2 occured while loading the Java VM

The error in the title come out when i tried to install a stock trading software,is there any method to fix it?[ I have tried to install the software on another laptop to make sure it is not the problem of the software.Download link: https://www.osk188.com/page.jsp?name=download_apps]


* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Garvill,

Thank you for posting your query on Microsoft Community. I understand the inconvenience you are facing. I will certainly help you with this.

We need more information to assist further; I request you to answer the followings.

  1. Have you install all the pending Windows update on your PC?
  2. Are you facing the same issue while installing any other software too?
  3. Have you installed the latest Java VM on your PC?

I suggest you to check if installing pending updates offered from Windows Update fixes the issue.  

Refer to the section “Do I need to check for updates?” in below given link:

http://windows.microsoft.com/en-in/windows-8/windows-update-faq

Hope this information helps. Please post back with the results and the information asked, we will be glad to assist you further.

Thank you.

Did this solve your problem?

Sorry this didn't help.

42 people were helped by this reply


The error in the title come out when i tried to install a stock trading software,is there any method to fix it?[ I have tried to install the software on another laptop to make sure it is not the problem of the software.Download link: https://www.osk188.com/page.jsp?name=download_apps]

Hi Garvill,

I was having the same problem when I want to install OSK188 to my Windows 7 system too.

1 solution to it is that you can add a PATH variable to the system, steps as below :

1. From the Desktop, right-click the Computer icon and select Properties. If you don't have a Computer icon on your desktop, click the Start button, right-click the Computer option in the Start menu, and select Properties.

2. Click the Advanced System Settings link in the left side.

3. In the System Properties window, click on the Advanced tab, then click the Environment Variables button near the bottom of that tab.

4. In the Environment Variables window, highlight the Path variable in the "System variables" section and click the Edit button. Add or modify the path lines with the paths : "C:\Program files\Java\jre1.8.0_60\bin" (You may cross check the right path in your Program files\Java directory)

*Please note that each different directory is separated with a semicolon (;) so you just need to add a semicolon (;) after the existing path.

5. Relaunch the installer again and you will find it's running !

Happy Trading ^_^

Did this solve your problem?

Sorry this didn't help.

663 people were helped by this reply


Sorry, but in Windows 10 does not work.
Where is the problem?

Did this solve your problem?

Sorry this didn't help.

101 people were helped by this reply


fxxxking helpful ! tq!

Did this solve your problem?

Sorry this didn't help.

22 people were helped by this reply


OMG thanks dude!! been looking for more then 2 hours for this problem.

Did this solve your problem?

Sorry this didn't help.

14 people were helped by this reply


Hi that didn't solve my problem.

Installed java 6.45 along with java 8.60 and I manage to run the java application that had problems.

Best regards.

Did this solve your problem?

Sorry this didn't help.


I have installed Java, and it's up to date.  I have not (knowingly, at least) installed Java VM.  Is this installed automatically when I install Java, or does it involve a separate install?

Did this solve your problem?

Sorry this didn't help.

24 people were helped by this reply


I had the same problem . It was more likely caused by the existence of C:\ProgramData\Oracle\Java\javapath; in the system variables path. When deleted, everything works just fine.

Did this solve your problem?

Sorry this didn't help.

206 people were helped by this reply


I had the same problem while trying to install Mobilefirst CLI 6.3

I was getting the following error while running the install_windows.exe

windows error 2 occured while loading jvm.

I did the following steps to resolve this.

1) Went to cmd prompt and change to directory where Mobilefirst CLI installer directory is located.

2) Run the following command

install_windows.exe LAX_VM "C:\Program Files\Java\jdk1.7.0_80\bin\java.exe"

This resolved the issue

Did this solve your problem?

Sorry this didn't help.

23 people were helped by this reply


Hi Evgeni

i have the same error
 did you solve problem?

Did this solve your problem?

Sorry this didn't help.

24 people were helped by this reply


* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
Question Info

Views: 176,097 Last updated: July 23, 2018 Applies to: