Permanently Disable Touchscreen Keyboard in Windows 8.1

I just discovered how to permanently disable the touchscreen keyboard from within the Windows 8.1 system, for users of touchscreen laptops with physical keyboards (so will never need the on-screen touch keyboard):

Open Explorer
 1. Tap "This PC" in left column
 2. Tap "Computer" tab
 3. Tap "Manage" on upper right
 
Then in column on left:
 1. Tap "Computers"
 2. Tap "Computer Management"
 3. Double-Tap "Services and Application"
 4. Double-Tap "Services"
        Scroll down to "Touch Keyboard and..."
         Tap "Turn off" on upper left

Then in far right column: 
   1. Tap "More Actions" under "Keyboard"
   2. Tap "Properties"
   3.  Next to "Startup type:" select "disabled"

I restarted my computer to make sure the touch keyboard really was disabled - and it is. Finally. After a lot of hassle.

BTW, I stumbled across this quite by accident. Microsoft REALLY needs to make this more obvious for people as there are complaints all over the web about it. 

Was this discussion helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this discussion?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this discussion?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Thank you so much for this!

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

thank you so much. this has been an annoyance since I first purchased it.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks for your suggestions. I've read this before in many other forums and I use those settings myself because they do provide a partial solution to this little annoyance, but not a permanent one, at least not in my case.

In my case the above steps will prevent the touch keyboard icon from displaying in the taskbar when I first turn on my laptop, however once my laptop recovers from sleep more the keyboard icon is once again miraculously populating it little home in the taskbar.

Am I alone here or is this also happening to others?

 

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thank you for a quick fix of the most annoying computer problem I've seen in years!

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I just discovered how to permanently disable the touchscreen keyboard from within the Windows 8.1 system, for users of touchscreen laptops with physical keyboards (so will never need the on-screen touch keyboard):

Open Explorer
 1. Tap "This PC" in left column
 2. Tap "Computer" tab
 3. Tap "Manage" on upper right
 
Then in column on left:
 1. Tap "Computers"
 2. Tap "Computer Management"
 3. Double-Tap "Services and Application"
 4. Double-Tap "Services"
        Scroll down to "Touch Keyboard and..."
         Tap "Turn off" on upper left

Then in far right column: 
   1. Tap "More Actions" under "Keyboard"
   2. Tap "Properties"
   3.  Next to "Startup type:" select "disabled"

I restarted my computer to make sure the touch keyboard really was disabled - and it is. Finally. After a lot of hassle.

BTW, I stumbled across this quite by accident. Microsoft REALLY needs to make this more obvious for people as there are complaints all over the web about it. 

I already had done that.  However, whenever my computer awakes from sleep, that darn icon is present again.  It is non-functional, but it annoys me that it recurs, and the toolbars tab under Taskbar Navigation and Properties shows touch keypad again enabled.  They need to fix this bug.

-patchdoc

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I've followed these steps, but still get the Touch Keyboard each time I reboot

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I've followed these steps, but still get the Touch Keyboard each time I reboot

Make sure you have st the service startup to disable

- Hayden Andreyka

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Did you disable it from the "start-up"?  This would be key to ensuring that this didn't happen.  The above steps worked for me, so if they don't for you than it's something else and I sympathize with you my friend.  HATE that keyboard!  :)  

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I spent a few months trying to get rid of the stupid icon, succeeding in June 2014 on an Asus 400. However it recently came back. Curses. Maybe a Windows update or something that I did. A lot of research on this and other posts failed to kill it permanently (returned after sleep). However I did find one post that seems to work (though a bit technical). In http://superuser.com/questions/488322/permanently-remove-disable-touch-keyboard-in-windows-8-taskbar/860576#860576 Thanks Martin Hansen

  • Open regedit and navigate to HKEY_CLASSES_ROOT
  • Then open search and search for "Tablet PC Input Panel"
  • After you found it, delete the whole CLSID folder it's in. For me it was "{15D633E2-AD00-465b-9EC7-F56B7CDF8E27}". Backup / export the key before in case something goes wrong.
  • You will have to take ownership for this key to be able to delete it. To do this, right-click the CLSID key (folder) and every one of its sub-keys individually, open the permissions menu, and take ownership for all keys.

After this, the toolbar was gone for good. A safer way should be to deny system read permissions for this key, however Martin didn't have the time to figure out how (and I (jonricho) wouldn't know where to start!

If you don't know how to take ownership of the keys and subkeys, this may not be the best solution for you. But you can look it up. As long as you back up the key, you should be ok. 

I should also mention that it removed my desktop and quicklaunch toolbars at the same time (after a reboot) but they were easily re-established. Will post again if any problems emerge.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I had no success with disabling it under Computer Management. I recently changed hard drive and noticed that it first appeared after a Logitech keyboard driver download from Microsoft update. Hmmm...

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Discussion Info


Last updated February 21, 2021 Views 13,387 Applies to: