Mouse stickiness change with multiple monitors after Windows 8.1 Update 1: Bug or feature?

There is a new bug that won't let the mouse to the other screen unless you move the mouse quickly across the monitor edge. Before, this would only happen on the corner edges to allow easier access to the charms and apps bar. Now, it happens to the whole edge.

These four videos demonstrate that the mouse stickiness issue happens in both desktop and metro mode and that it is inconsistent - only happening sometimes. I hope these videos help paint a clear picture of what is going on.

Desktop Mode

http://youtu.be/-0mrPXXtkfw

 No bug

http://youtu.be/3TVYvu4Yi5g

 Bug

Metro Applications

http://youtu.be/hOEeo9r0xs8

 No bug

http://youtu.be/b-Usdhnvl3A

 Bug

Is this issue already known and will there be a hotfix, or is this a new feature?

November 12th 2014 Update

Mouse stickiness still a problem as of today for Windows 8.1. As of Windows 10 Build 9879 which was released today, the mouse stickiness is fixed! This mouse stickiness only happens when dragging a window around and is used to assist in snapping windows. Outside of this, the stickiness issue is gone! I think this was what Microsoft intended to do with the mouse stickiness, but I believe it was a hard bug to diagnose, but they finally fixed it!

November 2nd 2014 Update

Mouse stickiness still a problem as of today for Windows 8.1. As of Build 9860 of Windows 10 Technical Preview, the mouse stickiness bug/feature has started happening.

June 9th 2014 Update

Still no official word from Microsoft. I have found a fix, but it is more of a workaround. Just don't use any metro apps, and it should be fine. Very rarely you will get the stickiness again. If it does occur anyways just press WIN + P and click Duplicate. After all monitors are duplicated, press WIN + P again and then click Extend to go back, and the mouse stickiness issue should be gone.

May 16th 2014 Update

According to Shawn "Cmdr" Keene [MVP] at the end of page 2, this is NOT a bug and it is an intentional design. I hope that Shawn is incorrect and would like further verification by an employee of the Windows development team.

There is also a "fix" by editing some registry values, but this removes the mouse stickiness on the corners and makes it very hard to access the apps and charms bar in between monitors. I do not believe this is a fix to the problem.

May 5th 2014 Update

Still no word from Microsoft that this is a bug or feature.

|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I tried the registry tweak for escape velocity, did both entries, restarted and it seemed to work. then it came back....

really frustrating. 

I found that if you win+p, and then click duplicate, then win+p again and go back to extend it fixes the problem relatively quick.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This is beyond annoying and i can't believe that microsoft has not sorted it out yet, i'm going insane over this problem. While windows 8 is great in all other aspects it boogles my mind they are enforcing the god damn "charms bar" on people who are on desktop computers with zero touch capabilities. This charms bar is completely useless and in the way of me working with a multi monitor setup, i cannot believe this have not been fixed yet, get your **** together microsoft, there's a reason why people are buying macs

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

After messing around with this issue I think I found out what is the "intended feature" and how to avoid it.

When you have a metro app open, a new bar appears at the top (to drag around to move the metro app to different monitors, or minimize, or close the app.

This bar only appears when the mouse is at the top of the screen (or for a short period of time after you open the metro app).

When this bar is visible, then the mouse will be sticky-edged on all monitors for the full border.

If you wait the period of time for the bar to disappear, the sticky-edges will disappear and revert to how they performed in windows 8.1 (pre-update 1). It will only be sticky near the corners.

I think the main problem is, if you use the minimize, or close option on the bar of the metro app then windows considers this option still "on" so the mouse will be sticky-edged.

The way I avoid this if I want to minimize or close the metro app is by:

1- opening metro app.

2- wait for bar to disappear (by keeping mouse away from top)

3- Alt+Tab to a desktop app. (Or drag a desktop window from different monitor and overlap the metro app which minimizes the app)

4- If I want to close the app, I right click on the app in the taskbar and close it. If I want it minimized I just drag a window from the desktop (on a diff monitor) on top of the metro app to minimize it.

Either way, I feel that this new "metro bar" at the top of metro apps isn't optimal for PCs with multiple monitors.

Hopefully in the next update the either add an option or remove the 'sticky edges' association with their new metro-app bar.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Sorry. This does not work for me.

I have used the registry edits with no solid success.

I tried your recommendation to open a metro app, let the title bar hide and then alt tab out to the desktop...

The moment that I do not move my mouse fast enough to "escape" the screen... the problem becomes much worse. I mean it literally forces me to jerk the mouse across the edge in order to swap.

Microsoft needs to remove this feature until they get it fixed... or give us the checkbox to turn it off, since the registry edit isn't working for everyone.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

i'm with you brother! Microsoft now expects us to execute brand new mouse gymnastic routines just to simply move a stupid window across. insane.
MT

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I just downloaded the 8.1 update and am having the same problem. This is so annoying. I really wish I just left things as they were. Is there any way to go back to the old version of Windows?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 have used the registry edits with no solid success.

Does that mean the registry value is going back to default somehow?  If so and you know the frequency of occurrence (or can stand the overhead) you could run ProcMon to capture when it happens.  Supposedly there is also a method of tracking registry events using Auditing but I am only familiar with using ProcMon to do this.

HTH

Robert Aldwinckle
---

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

My mouse was still sluggish after going through all the fixes in this thread. I then thought that it might be an issue with my screen since I am trying to get it to work on my secondary screen which is a 32" LG. After switching my secondary monitor to "Game" mode in the picture settings of the screen itself, the problem went away.

Could it be a refresh rate problem? When I was in any other mode the mouse was lagging and felt "heavy" across my extended desktop.

My original monitor (22") was working fine and so I originally thought it was a driver issue or a resolution issue but I was already up to the max resolution.

I have tried this with 3 monitors now (LG, Samsung, and Sharp) and all are working fine once put in "Game" mode.

I hope this helps someone. This would have been a deal breaker for me had I not fixed the issue.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I hate this bug. I hate it so much.

I set the registry value. It still randomly pops up several times a day (I haven't been able to determine what triggers it). Every time I have to kill and restart explorer. This is slowly driving me insane as I never know if my mouse will make it to the other screen.

Why can't we get an official response on this. I fear the torment will not end until Windows 9. Maybe not even then.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This is very very VERY annoying:

I am the user and I know better than my PC, what I want to do. How does Microsoft dare, that they know better than me, how I want to use my mouse?

I work with 3 monitors on my PC since years, I know how to use a mouse. For me everything worked fine until yesterday (09.09.2014):

I bought a new mouse and this was the first time, I experienced this issue. 

So that means: old mice (Microsoft Comfort 6000, Logitech MX518) work fine. New mouse G502 does not work as it should...

Amzing featur: you have to use OLD devices to work (when you work the whole day, you get mad with this bug).

Someone mentioned registry entries... anyone has more details please?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated October 16, 2020 Views 32,549 Applies to: