Mouse cursor/pointer disappears on startup, but is visible in Lock screen

Hello,

so, I have this problem for quite a while and I've tried every possible solution I came up with myself and finally ended up helpless. It started when I upgraded my graphic card to GeForce GTX 660, but I've got the newest drivers (reinstalled a million times), so I can't imagine the problem is there.  

And what's the problem? It seems that every time I shut down my computer by its case button, on the next startup the cursor disappears, but only if I log in to my profile. If I somehow manage to log out, the cursor is back. But if I shut down the computer via Windows (by the button on Start screen for example), the problem is partially solved. Partially because sometimes it happens even with this procedure, so it's not a temporal solution. The funny thing is that if I restart the PC, it doesn't help and it doesn't matter whether it's by the case button or by Windows. I always have to shut down and then start again, no restarting. Thankfully, it doesn't occur if I put my PC in sleep mode. But I can't have my PC in sleep mode forever, can I, so still it's rather frustrating. I always have to navigate the invisible cursor on that shut down button on Start screen, which is really hard and takes ages. Oh yes, even if I turn on "Show mouse pointer position when ctrl is hold" or sth like that, that's not the solution, I want to prevent this from happening again.

I've tried changing every possible mouse pointer settings, nothing's worked so far. I also searched vastly on many forums but nothing addressed my particular problem. And I thought maybe I should partially restore the system, so I did that and it helped for a while, then the same problem occured again. And I have a HP notebook with 8.1 too, where this never showed up. So it's only in my PC, but what exactly?

I don't see how it could help, but these are my system specs:
CPU: AMD Phenom II X4 Black Edition 965 3,4 GHz

Motherboard: Asus M5A78L-M
RAM: Kingston (I forgot the type) 1x4 Gb

GPU: Asus Nvidia GeForce GTX 660 OC Edition

OS: Windows 8.1 Pro, with automatic updates enabled, so it's not outdated

Thank you for any help you can provide.

 

Question Info


Last updated August 7, 2018 Views 6,723 Applies to:
Answer

Found a work around on another site. Pressing Ctrl+Alt+Del, then press Escape. The mouse magically appears.

not sure if a gpu issue.

62 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.