Camera is not recognized

I updated from Windows 8.0 to Windows 8.1 yesterday.  Many problems have now been created.  Before 8.1, I could plug my Sony digital camera into a USB slot and upload my photographs.  Now it does not even recognize that the camera is plugged in.  It will recognize other things such as flash drives.  I take that as a sign that the USB ports are working properly.   I have a HP p62330 computer.  Thanks.



 

Question Info


Last updated May 23, 2018 Views 954 Applies to:

 

Hi Mark,

 

Please answer to these questions:

 

1)       What is the exact model number of your Sony Digital Camera device?

2)       Did you install the latest driver updates for the camera device from the Sony website?

 

This issue could be due to the incorrect/out dated camera drivers installed on the computer. I would suggest you to go to the Sony website and then download and install the latest Windows 8.1 drivers available for the camera model on the computer. If Windows 8.1 driver are not available then install the available driver in its compatibility mode and check if that resolves the issue.

 

To install it in compatibility mode, you may refer to this article:

 

Get your apps and devices working in Windows 8.1

 

For more information about Program Compatibility, you may also refer to these links:

 

What is program compatibility?

 

Program Compatibility Assistant: Frequently asked questions:

 

Hope this is helpful.

Regards,
Rajesh Govind - Microsoft Support Engineer

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My camera is a Sony F828 digital camera.  The latest drivers I can find are XP drivers.  I have tried to reinstall them.  I believe that I have reinstalled them correctly.  When I plug the camera in the USB port the Safely remove and eject media icon shows a Sony device.  "This Computer" does not show anything in the F or G drives which are ones I use to plug the camera.  I hope this helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.