Question

Q: Windows Store Broker problem: very high CPU usage

Starting several weeks ago (January 2014) the task Windows Store Broker (wshost.exe) starts randomly and quickly climbs up to 50-60% CPU usage - even if no "Metro" apps are running and I haven't opened the Windows Store. I can end the task in the Task Manager yet it starts again within minutes and begins using 50%of my CPU again. (See screenshot).

Full anti-virus scan reveals no problems.

Resetting the Windows Store (wsreset.exe) doesn't solve the issue.

I searched the Windows\WinSxS directory and found wshost.exe in 3 places. One of them was updated January 17, 2014. My guess is that this update caused the problem.

Anyone else having the same issue?

Anyone found a solution?

Is Microsoft aware of the issue and working on a solution?

My only resort for now is to disable the Windows Store via a registry entry to avoid my laptop continually overheating due to extremely high CPU usage.

I appreciate any help.

Answer

A:

Kill Store and Store Broker from task list.

Rename the Cache folder to CacheOld at:

C:\Users\(Your User Account)\AppData\Local\Packages\WinStore_cw5n1h2txyewy\LocalState

(Your WinStore_gobblygook might be a different bunch of gobbblygook)

Create an empty folder called Cache.

Solved! For me anyway.

Enjoy,

Ron

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply

Answer

A:

Select Options.

Folder options should appear:

Click the View tab then select "Show hidden files, folders and drives"

Select OK.

Proceed to Appdata

Did this solve your problem?

Sorry this didn't help.



 
Question Info

Views: 28,548 Last updated: May 31, 2018 Applies to: