windows 8.1 hangs on Please Wait screen (restoreoptin)

When logging in, a Please Wait screen shows up along with a Cancel button. I tried letting it sit there for more than half an hour but nothing happens. I noticed the application is letterboxed and I can use Win+D to see that the desktop show up. The screen stays on top blocking all mouse activity and most of my screen.

 

Eventually I logged into another account and found restoreoptin running and terminated it. That removed it from my original account however it will do it again if I log out and log back in.

 

Any ideas?

 

Question Info


Last updated October 14, 2019 Views 119,970 Applies to:
Answer
Answer

<Modifying post to help other find the answer quickly>


I found another workaround that allows for still using skydrive, and further confirms the relationship to skydrive setup.

(This is the method I used)

  1. login to the affected account
  2. Press Windows Key + L to lock the computer
  3. Switch to a user account with administrator priveledges
  4. open task manager & switch to the "Processes" tab (Press "More Details" if don't see a processes tab)
  5. find restoreoptin.exe & end task that process
  6. switch back to affected account (Start Page, click your account name/picture, click the account you want to switch to)
  7. Open Charm menu (windows key + C), select "Settings", then Change PC Settings
  8. Select Skydrive
  9. Modify the File Storage, Camera Roll, and Sync Settings (not sure which one does the trick)
  10. logout & log back in
  11. you should no longer be prompted with the blank 'please wait' screen


Another workaround that should achieve the same, as posted by others:

  1. login to the affected account
  2. Press Windows Key + r
  3. Type:
    taskkill /f /im restoreoptin.exe
  4. Open Charm menu (windows key + C), select "Settings", then Change PC Settings
  5. Select Skydrive
  6. Modify the File Storage, Camera Roll, and Sync Settings (not sure which one does the trick)
  7. logout & log back in
  8. you should no longer be prompted with the blank 'please wait' screen

and just for completeness, you could also try:

  1. login to the affected account
  2. Press: Windows Key + r
    Type:
    taskkill /f /im restoreoptin.exe
  3. Press: Windows Key + x
    Press: a
    Press: <Alt + Y>
    (run cmd as administrator)
  4. Type:
    cd c:\windows\system32

    restoreOptIn.exe /Ramp

  5. Complete the Wizard



14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer


I fixed it much more simply. I had to recently rebuild my dell xps 27 and started with 8.0. Setup everyone's account since I have a home network and domain setup. Then upgraded, I ran into the same issue as everyone here in the post. What I had to do to fix is is unassociated all the windows live/Hotmail/outlook accounts from the domain accounts and then re-apply them. This then asked me to verify that the account has permissions to skydrive, and asked for verification. Texted me, I put in the verification code and it was fixed on all accounts. Someone also mentioned making it a local account and then reassigning to your windows account. Seems to fix it as well.


Steps for Domain accounts:

1. Remove association from your windows account

2. Re-add your windows account

3. verify that the pc has permissions to back up your info to sky drive/turn off sync with sky drive.


Windows Account:

1. Make it a local account

2. Re-add your windows account

3. Verify that the pc has permissions to backup your info to sky drive/turn off sync with sky drive.


Appears to be a bug in the 8.1 upgrade where the pc and sky drive trust is broken, it didn't happen until I received a windows update, but I could see this happening if you download the patches during the upgrade process.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.