Question
6320 views

Windows 8.1 crashes with DRIVER_POWER_STATE_FAILURE after waking from sleep mode

SanderOttens asked on
Hello,

Since the upgrade from Windows 8 to 8.1 my ultrabook started giving some problems. Only when waking up from sleep mode it takes some time to start up till it gives a BSoD before it's completely started then it restarts and works again normally. When I shut it down and turn it on, it does take a little longer than normal to start, but gives no further problems.
After it's started I always get the message: 'your system does not appear to have Intel Rapid Start Technology enabled'. 

The specs of my machine:
Lenovo Ideapad u410
OS: Windows 8.1 x64
RAM: 8GB DDR3
CPU: Intel i7-3517U 1.90 GHZ
GPU: NVIDIA GeForce 610M and Intel HD graphics 4000
HDD: 1 TB 7200rpm 
SSD: 32GB

What I already tried to do is update all the drivers, updated a few but made no changes. I can't get into my BIOS, so could change anything there.
I tried to do a system file check, four times. All four times I got the msg: Windows Resource Protection found corrupt files but was unable to fix some (or all) of them.

I haven't tried to refresh or reïnstall the system because I would rather not have to install everything all over again. I hope there is something I could do without having to reïnstall.

1 person had this question

Abuse history


The answered status icon Answer
Patrick Barker replied on

Sander, unfortunately, the culprit is still iaStorA.sys. This is not simply a driver we can remove and replace as more than 90% of the time once it's removed, you can no longer boot. You can try one thing, or you can do a clean install of Windows and not install the IRST driver at all and allow Windows to keep the default driver.

First off, let's create a Restore Point - http://www.eightforums.com/tutorials/4690-restore-point-create-windows-8-a.html

Head to Device Manager > IDE ATA/ATAPI controllers, change the drivers for the Intel (also works for AMD/Nvidia - enables TRIM for SSDs and allows SSD software to access the drive for firmware updates, etc.) to the standard AHCI 1.0 Serial ATA Controller. Do this by selecting "Let me pick from a list of device drivers on my computer" and then choose the "Standard AHCI 1.0 Serial ATA Controller" (it's the inbuilt Windows driver for AHCI SATA). Apply/OK your way back out of Device Manager.

Reopen Device Manager and check that the MS driver has 'stuck'. Then, still in Device Manager, select 'View' > 'Show hidden devices' and open the 'Non-plug and play Drivers' section and right-click on iaStore A, select Properties then the Drivers tab; under Startup, change the Type to Disabled, Apply it and then you should be prompted to reboot - do it.

Wait a few moments after the reboot - if Windows prompts that you need to reboot again, it may have re-enabled it - reboot if needed then check that iaStoreA is still disabled.

Or, as I said, run a clean install of Windows and don't install IRST.

Regards,

Patrick
Debugger/Reverse Engineer.
3 people found this helpful

Abuse history


progress