Task scheduler cannot start a task. Error 0x41301

I faced quite an odd issue. I created task for starting Transmission-QT at system start.
I enabled Task History and there all seems fine.

But really program doesn't start. In "Last run result" field of Task Scheduler I get a strange error 0x41301. 

I googled it and discovered that it means "Task is already running". Surprisingly I found this program in running tasks just after system boot but no GUI is shown. Only the process itself is running.

But after some time it dissapeared from Task Manager and then nothing happens.
I googled this error and tried all the proposed solutions: I set up option "Log on as a batch job", I specified "Start in" parameter explicitly in task definition, but had no luck.
Anybody has any suggestions? 

 

Question Info


Last updated September 19, 2018 Views 71,509 Applies to:

Hi,

That code just means that the task is running. You can actually see that in your screenshot even if you look to the left of it under the column called "Status". 

See this article for more info: https://msdn.microsoft.com/en-us/library/windows/desktop/aa383604%28v=vs.85%29.aspx?f=255&MSPPError=-2147217396

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It is all wonderful but how will it help me in practice?

I was aware the error code but I cannot guess WHY the task seems already running to system. I made in accordance with the standard process and see no reasons for this.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It depends on what you've configured in the settings for it.

For example, the task called RAC handles the Reliability Monitor the latter of which is accessible by clicking the Action Center icon (looks like a flag) on the taskbar and then click the down arrow in Maintenance. You can see from that what's happening on the machine by clicking the link to Reliability history.

But I don't want to to be running all the time and therefore I've configured the Conditions menu to only start the task if the computer has been idle for ten minutes and to wait for one hour for that to happen. In that respect, the default is one minute. Here's a screenshot of that.

If left on the default setting it generates a message that an app needs to close before the computer can be shutdown since it will start if I don't touch the keyboard or move the mouse for 60 seconds.

The Trigger menu also plays a role in deciding when to run the task.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I haven't got such sophisticated conditions, so it is not the case.

Any other suggestions?

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Maybe it's dependent on the way the torrent client is configured: http://sourceforge.net/projects/trqtw/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Maybe. But I don't know wich settings.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I can't help you there since I don't use it.

Some clues here perhaps: http://sourceforge.net/p/trqtw/discussion/1315796/thread/7bbd2fce/?limit=25#ff49

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.