QoS Packet Scheduler Bug

Hi,

My desktop (HP Pavilion 500-047cb) has been getting very slow internet speed with the wired network adapter.   Today, when installing a wireless network adapter the same symptoms appeared on the new adapter (NetGear A6210.  So, I began researching the issue and noticed what appears to be a QoS bug.  Some details on the system are below.

When I boot using the Netgear adapter with QoS (for Netgear) set to "on" and then turn "off" QoS then I am able to get a download speed of 30Mb.  Please see the screen shots below.  If I boot with QoS "on" or boot with QoS "off" then the network speed is dramatically slower (as shown in the 3rd screen shot).  This "boost to expected bandwidth" is repeatable.    

It may be possible to produce the same result with the Nic on the motherboard.  However, I haven't had time to test.  Any solutions are welcomed.  Thanks.

Donald

 

Question Info


Last updated March 22, 2019 Views 3,810 Applies to:

Hello Donald,

Thank you for visiting Microsoft Forums.

I really appreciate the detailed description of the issue and your efforts towards finding the reason for this issue.

Networking Quality of Service (QoS) is a techniques through which network traffic is prioritized, that helps to improve transmission speed to most relevant application. QoS Packet Scheduler is installed by default for local area network (LAN) connections.

The default system behavior is that all 100% bandwidth is available, however, if there is a running application that indicates to the OS it needs to send high priority/real time data, then as long as it has the socket open, Windows will restrict “best effort” traffic to 80% of the bandwidth so that high priority traffic can be accommodated. Basically, applications can make this request to the operating system for QoS support using the QoS application programming interfaces (APIs) in Windows and this only applies if a specific app is requesting QoS.

If you'd like to change how much bandwidth is reserved for QoS (the default is 20% of the total bandwidth), do the following:

Note: Please have a restore point created on the computer before performing the task below, if incorrect steps are applied we can revert back to the original settings with this restore point.

 1. Make sure you're logged in as "Administrator".

 2. Navigate to START, Run and type: gpedit.msc

 3. Navigate to Local Computer Policy > Administrative Templates > Network > QOS Packet Scheduler

 4. In the right window, double-click the limit reservable bandwidth setting

 5. On the setting tab, check the enabled setting.

 6. Where it says "Bandwidth limit %", change it to read 0 (or whatever percentage you want to reserve for high priority QoS data)

 7. Click OK, close gpedit.msc

Under START > This PC > My Network Connections > View Network Connections, right-click on your connection and under Properties (where it lists your protocols), make sure QOS Packet Scheduler is enabled.

However, if you do not need to prioritize network traffic and its works fine without QoS packet scheduler you may choose to keep it disabled.

Hope this information is helpful. Feel free to write us back for any further assistance with Windows, we’ll be glad to assist you.

Regards,
Mann Manohar

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.