• July 17, 2017
    Announcement: New site design for Microsoft Community

    In July, Microsoft will roll out the first of ongoing site improvements aimed to modernize Microsoft Community and help customers get the most out of their community experience.

    • During the roll out period, you may see the old or new site design depending on your location

    • We expect the roll out to finish by 31 July

    Note: Past private message conversations will not move to the new site design. Please save any private messages you would like to keep.

     Learn more about the upcoming site improvements in this thread.

    Thank you for being part of Microsoft Community!

 
Question
16319 views

How to enable Readyboost that is disabled in error

M.Pollack asked on

My laptop came pre-installed with Windows 8.1 on a 500GB 5400RPM HDD. It has 4GB memory.


Over the holidays someone gave me a 64GB m-SATA SSD, which I put into the laptop's m-SATA slot.


On the BIOS, the info shows that the SSD occupies the SATA 0 slot. I had to re-adjust the boot order to boot normally into my system disk, which is on the SATA 1 slot.


I wanted to use the m-SATA SSD as a Readyboost cache. When I carried out the steps to enable Readyboost on the SSD, it wouldn't let me. The error message is:


This device cannot be used for ReadyBoost.

ReadyBoost is not enabled because this computer is fast enough that ReadyBoost is unlikely to provide additional benefit.



There must be some mistake because the SSD is not the system disk. It only occupies SATA slot 0 (which I cannot change). The system disk is a typical HDD.


How do I go about enabling Readyboost on the SSD? Any tweaks or commands? I have tweaked the registry many times before so if need be I could do that.



[Note: Those who want to suggest other things like sell the SSD, leave it alone, or whatever, please just heckle some other thread.]



28 people had this question

Abuse history


The answered status icon Answer
JimWynne replied on

Insert the flash drive or card, then right-click on it in This PC and select properties.  Open the ReadyBoost tab.

Not a Microsoft employee; just here to help.
3 people found this helpful

Abuse history


Most Helpful Reply
M.Pollack replied on

To those who continue to clog this thread with YOU DON'T NEED IT, YOU'RE WASTING YOUR TIME kind of replies, despite my polite request to stay off in the First Thread:


I have other machines with Windows 7, running 4GB, and running Readyboost off a small, non-system SSD attached in an internal SATA port. I find that it helps with booting times and it feels faster.

 

Anyway, in this laptop, running Windows 8.1, the option to use Readyboost should be available. But it seems that Readyboost is detecting the non-system disk SSD connected on SATA Slot 0 as SYSTEM DISK and therefore not even making the ReadyBoost option available.


Gordon B-P and Mike Hall MVP, if you want to help me get Readyboost to work or work around the bug, I appreciate it. If you want to clog this thread with non-help and irrelevant observations, despite the fact that the issue is very clearly stated in the first post, please just stay away.



18 people found this helpful

Abuse history


progress