Error - Event ID: 10016; DistributedCOM

I am getting this error repeatedly since I updated from Windows 8 to 8.1. It occurs once every time the PC is booted, about 2 minutes after it boots up.

 

Can you please help me to fix it?

 

Log Name:      System
Source:        Microsoft-Windows-DistributedCOM
Date:          10/20/2013 3:19:04 PM
Event ID:      10016
Task Category: None
Level:         Error
Keywords:      Classic
User:          LOCAL SERVICE
Computer:     
Description:
The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{C2F03A33-21F5-47FA-B4BB-156362A2F239}
 and APPID
{316CDED5-E4AE-4B15-9113-7055D84DCC97}
 to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

 

The APPID {316CDED5-E4AE-4B15-9113-7055D84DCC97} is for a COM application called "Immersive Shell". I cannot use the Component Services administrative tool to edit the security permissions because every setting is "grayed-out".

 

I tried running in Safe Mode and was still unable to modify any of the Immersive Shell settings.

 

The PC has no software installed except for the latest Intel drivers. I performed a clean installation of Windows 8, installed chipset, VGA, Intel Rapid Storage Tech, LAN, and Intel Management Engine drivers. Then I updated to 8.1 through the Store app. The errors began immediately after that update.

 

The PC has an ASUS Z87 motherboard, 16 Gb of DDR3-1866 ram, Intel i7-4770k cpu. It is not overclocked but memory is in XMP mode at frequency 1866. The system drive is an SSD.

 

Question Info


Last updated November 14, 2019 Views 504,572 Applies to:
Answer
Answer
In system event viewer, I started getting error Event ID: 10016 after upgrading to Win8.1 on October 17, 2013.  The system event viewer on my Dell XPS One 2710 was error free prior to upgrading from Win8 to Win8.1.

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID {C2F03A33-21F5-47FA-B4BB-156362A2F239} and APPID 
{316CDED5-E4AE-4B15-9113-7055D84DCC97}  to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

For me, the solution was provided by Greg310 in Dulwichdik's link as follows:

1. Open Regedit
2. Go to HKEY_Classes_Root\CLSID\{C2F03A33-21F5-47FA-B4BB-156362A2F239} 
3. Right click on it then select permissions  
4. Click Advance and change the owner to Administrators group. Also click the box that will appear below the owner line. ("Replace owner ...")
5. Apply full control 

6. Go to HKEY_LocalMachine\Software\Classes\AppID\{316CDED5-E4AE-4B15-9113-7055D84DCC97} 
7. Right click on it then select permission 
8. Click Advance and change the owner to Administrators group
9. Click the box that will appear below the owner line 
10. Click Apply and grant full control to the Administrators group

11. Go to Administrative tools 
12. Open component services 
13. Click Computer, click my computer, then click DCOM 
14. Look for the corresponding service that appears on the error viewer [Immersive Shell]
15. Right click on it then click properties 
16. Click security tab then click Add User. Add Local Service then apply 
17. Tick the Activate local box 

Thank you Daniel MoisesMagulado and Greg310 for addressing the problem and providing the solution!

614 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.