Disabling Windows Compatability Telemetry

Does anybody know how to stop the Windows Compatability Telemetry (CompatTelRunner.exe) from starting? It causes extremely high disk usage which results in large performance issues.
 

Question Info


Last updated June 23, 2019 Views 506,635 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Nancy,

To disable Windows Compatibility Telemetry, kindly follow these steps:

  1. On the search box, type services and press Enter to open the Services desktop app.
  2. Stop the Diagnostics Tracking Service and change the Startup Type to Disabled.

Additionally, you can use PowerShell to stop the Diagnostics Tracking Service and change the Startup Type to disabled. To do so, open PowerShell and run these commands:

stop-service diagtrack
set-service diagtrack -startuptype disabled

Let us know how it works.

Regards.

19 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think we have finally found the problem.  It's simply Microsoft and their **** updates followed by a jungle of pointers to conflicting places that do not fix the problem.  These clowns are never going to issue a stable version of the OS.

Solution: Save your files.  Wipe your drive, and install Linux.

41 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Nancy,

To disable Windows Compatibility Telemetry, kindly follow these steps:

  1. On the search box, type services and press Enter to open the Services desktop app.
  2. Stop the Diagnostics Tracking Service and change the Startup Type to Disabled.

Additionally, you can use PowerShell to stop the Diagnostics Tracking Service and change the Startup Type to disabled. To do so, open PowerShell and run these commands:

stop-service diagtrack
set-service diagtrack -startuptype disabled

Let us know how it works.

Regards.

Just a heads up, they changed the display name from Diagnostics Tracking Service to Connected User Experiences and Telemetry. The real name is still diagtrack in PowerShell and the services tab under Task Manager though. I guess they thought people wouldn't like to see "Tracking Service" running on their PC, so they made it go incognito.

27 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just a heads up, they changed the display name from Diagnostics Tracking Service to Connected User Experiences and Telemetry. The real name is still diagtrack in PowerShell and the services tab under Task Manager though. I guess they thought people wouldn't like to see "Tracking Service" running on their PC, so they made it go incognito.

Thank you! this fixed it for me

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, I was having the same problem and I just did these steps:

1. Press Windows button

2. Search for Feedback and Diagnostics

3. Put Diagnostic and usage data level to "Basic"

Now the process is not using too much Disk. By the way it was selected the "full" option, and that's why I was having so much Disk Usage.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Oh, I had no idea that option existed. However that wasn't the issue for me because it was set to basic by my school (this is my own computer but I am using a copy of Office 365 that they gave me for free, it take over some privacy settings and disables sending typing data to improve predictions and apparently setting telemetry to basic. 

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having a similar problem but do not have the specific update installed.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Seriously? Telemetry is back to using 100% disk throughput after I killed it with fire less than two weeks ago. And now it's brought a friend, when Windows Compatability Telemetry stopped Microsoft Windows (R) System Protection kicked in, also ramping up to 100% although it finished after about 2 minutes. The worst part is that I have the Windows Compatability Telemetry service disabled (it was listed as stopped while Telemetry was hogging my disk) and it's also turned off in the settings app, yet it still manages to rise from the dead and freeze up my programs.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

To better assist you, we suggest that you post your query on our TechNet forums. Click here.

Regards.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There is no such option in Windows 10 at the location at the end of this, another, garden path..

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.