Can Not Turn on File History; Win 8.1 Pro

I have a brand new computer with a fresh install of Windows 8.1 Pro.  After installing a few programs I plugged in a 1T. external USB drive to use for back up.  The drive is freshly re-formatted.


When I try to set up the Back Up, it searches and finds the drive, bit when I try to turn the File History on I get a message "Could Not Enable File History.  either the device is disabled or no enabled device is associated with it."


I can dump a drive image file to the USB drive and read/write to it.  I'm not sure how to "associate" the drive with File History.  Any suggestions would be appreciated.

Thanks.

 

Question Info


Last updated July 17, 2019 Views 1,429 Applies to:
I have exactly the same issue. Have a 1TB external drive with 822GB Free. It can see the drive but it won't use it.  I did a system Image backup to the same external drive with no problems.  File History just refuses to turn ON !!!

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have exactly the same problem.  Trying to use an internal secondary SATA drive.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

C'mon Microsoft, only been 8 months. 8,1 is one weird, goofy, buggie OS, charmed I'm sure.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You have to turn on the Windows Search service (the indexing service). After that, no problem with File History.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

I have always backed up to an external hard drive with Vista and since upgrading to windows 8 then 8.1 I cannot seem to do this.  I plug my external hard drive in and it won't detect it to then allow me turn the file history setting on.  I have added the drive to the indexing list (I think) but still no joy.  Can anyone help as i would like to back up my files...?  Please keep help simple as I am still familiarising to windows 8.

Thanks in advance

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

I have always backed up to an external hard drive with Vista and since upgrading to windows 8 then 8.1 I cannot seem to do this.  I plug my external hard drive in and it won't detect it to then allow me turn the file history setting on.  I have added the drive to the indexing list (I think) but still no joy.  Can anyone help as i would like to back up my files...?  Please keep help simple as I am still familiarising to windows 8.

Thanks in advance

You have to turn on the Windows Search service in the following manner:

http://www.sevenforums.com/tutorials/2495-services-start-disable.html

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

Thanks but that  link is for windows 7...all looks technical too and as I have 8.1 don't want to start something that is wrong..?  Any more help..?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It's absolutely the same for Windows 8.1, and not so technical. See the link, Option 1, and on figure under point 4 you can see just the required service highlighted. To start it, you have to change "disabled" to "automatic". That's all.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.