Question
184 views

BSOD- multiple-irp-complete-requests

GiovanniGalati asked on

Hi, I've been getting the BSOD for this reason a lot lately can someone help me? Im not that expierienced with this kind of thing so please make it simple :) here are my dump files.

https://onedrive.live.com/redir?resid=57618BA961EA5DF7!107&authkey=!AOYKfzbHeG9XiVM&ithint=file%2c.zip

1 person had this question

Abuse history


The answered status icon Answer
Patrick Barker replied on

Hi,


We have a few different bug checks:


MULTIPLE_IRP_COMPLETE_REQUESTS (0x44)

This indicates that a driver has tried to request an IRP be completed that is already complete.


-- FAILURE_BUCKET_ID:  X64_0x44_IMAGE_AVer330U


^^ AVerMedia H264 Codec driver.


Update ASAP or remove software/driver/device - http://www.avermedia.com/Support/Download.aspx?Type=Software


As it's a minidump, we cannot really debug this type of bugcheck any further.


DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)

This indicates that a kernel-mode driver attempted to access pageable memory at a process IRQL that was too high.

A driver tried to access an address that is pageable (or that is completely invalid) while the IRQL was too high. This bug check is usually caused by drivers that have used improper addresses.


SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007e)

This indicates that a system thread generated an exception which the error handler did not catch.


BugCheck 1000007E, {ffffffffc0000005, fffff80001cbb52f, ffffd0002b2edfd8, ffffd0002b2ed7e0}


^^ The 1st parameter of the bug check is 0xc0000005 which indicates an access violation occurred. I cannot seem to run .cxr to see what caused it.


Let's look at the call stack:


0: kd> kv
Child-SP          RetAddr           : Args to Child                                                           : Call Site
ffffd000`2b2ee210 00000000`00000204 : fffff803`3e1bce64 ffffe000`00000000 00000025`d0960000 ffffe000`0363cae0 : atikmdag+0xb752f
ffffd000`2b2ee218 fffff803`3e1bce64 : ffffe000`00000000 00000025`d0960000 ffffe000`0363cae0 fffff800`01cbc35d : 0x204
ffffd000`2b2ee220 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!MiUnmapViewOfSection+0x12c


atikmdag.sys (AMD/ATI video driver) called directly into the bugcheck. It was likely where the violation occurred as well.


Ensure you have the latest video card drivers. If you are already on the latest video card drivers, uninstall and install a version or a few versions behind the latest to ensure it's not a latest driver only issue. If you have already experimented with the latest video card driver and many previous versions, please give the beta driver for your card a try.


-------------------


1. AODDriver2.sys is listed and loaded in your modules list which is AMD Overdrive; also in EasyTune6 for Gigabyte motherboard. Known BSOD issues in Win7 & 8.

Please uninstall either software ASAP! If you cannot find either software to uninstall, or it's not installed, please navigate to the following filepath:

C:\Program Files\ATI Technologies\ATI.ACE\Fuel\amd64\AODDriver2.sys

and rename AODDriver2.sys to AODDriver.2old

and then Restart.

2. Uninstall AsRock App Charger ASAP, as well as any other AsRock software (I also see RamDisk).

Regards,

Patrick

Debugger/Reverse Engineer.
Be the first person to mark this helpful

Abuse history


progress