Windows 8.1: WiFi dropping and/or "Limited"

Since installing 8.1 Pro, I'm having issues with WiFi dropping internet connectivity and always showing "Limited" when clicking on the system tray icon.  When I troubleshoot the problem using the system tool it is always the gateway that is faulty.  I have uninstalled/reinstalled the device drivers several times, installed the newest drivers directly from Intel, restarted the computer, etc.  I can restore connectivity by turning WiFi off then back on, but the connection will drop at what seems to be random intervals.  My applicable system specs are as follows;


Lenovo Y510P  Laptop

Windows 8.1 Pro

Intel Centrino Wireless-N 2230

Apple Time Capsule router w/newest firmware


Needless to say this is quite an irritating bug that didn't exist prior to the update to 8.1  I hope this can be resolved quickly. Thanks!



 

Question Info


Last updated January 18, 2020 Views 281,198 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

NICE JOB Seth.  Just bought a Samsung ATIV 9 plus (a real doll baby I ms say).  I am road warrior and use Ipad Personal hotspot for internet w my laptop.  Great connectivity, no internet, Win 8.1. On a 64 bit machine.  Changed wireless driver from Intel to the Microsoft version 16.0.0.62.  Bam.  Works flawlessly. Thanks much!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just bought a  1400$ Lenovo Yoga 2 pro a week ago and everything was fine when I had windows 8.1. Then I had to install 8.1 Pro to run Hyper V with Visual Studio 2013 to do some programming and now the wifi network shows ''limited''. Can't access web pages anything and ALL  my other devices at home work perfectly fine. 

I did try to change the Network  drivers in the Device Manager but it didn't change anything. I really don't know what to do next.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Marc,

As far as testing goes you can run the internet diagnostics function and review the log to see what the cause is.  My log had 50% dropped packets, difficult security handshakes and blamed the router for not resolving the DNS. You can also turn off security for a test. On my router I can configure guest access separately so I set up a temporary non secured SSID the problem should go away if it is driver/router based. Third you could try to get off AES security although that does cost speed.

My suggestion is to determine the maker of the tcpip chip set through device manager and update it to the most current version from the Mfg website. It might not install automatically on check for updates. Once  that is done check for router firmware updates. When the two were in sync my problem went away and the connection went much faster.

Doing all the above fixed my Windows 8.1 update issue but caused my old Roku to fail on AES, started to get slow blank screens and not authorized for Netflix. I already had a new Roku 2 so I installed the more current one and the problem went away.

Overall I think there are two basic problems in this thread resulting in the different answers.

1) Some people do not want the internet connection to go down at all. The power management and TCPIP settings seem to fix that by leaving the adapter on and not allowing the connection to time out.

2) There is also a driver version issue related to security protocols especially WPA2-AES that does not exist in WPA-TKIP. This seems to be fixed by driver and router firmware to get the latest standards.

Hope this helps!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the Alienware M18-R2

Running Win 8 (didn't want to upgrade until I knew all bugs were fixed)

Qualcomm Atheros Osprey Wireless Network Adapter

Well, so much for trying to stay safe on Win 8......

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So after wasting a full day, I was finally able to have my connection back! All I did was reset my router. I also downloaded all the latest drivers from both Lenovo(have a Yoga 2 Pro) and Intel website. I'm not an expert in computing but this website also really seemed to help, I followed the instructions about the TCP/IP settings.

http://optimizewindows8.wordpress.com/2013/11/07/how-to-fix-limited-wi-fi-connectivity-issue-in-windows-8-1/

My connection still shows ''limited'' but I can go to internet, run apps, netflix without  problems.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have a Lenovo Z580 with an Intel(R) Centrino(R) Wireless-N 2200, that was having this same problem Windows 8.1. Would be online for only a few moments then constantly going offline, limited connections, etc. The solution I found was as follows

 

Get to your Device Manager window (Start Menu==>Type: Device Manager ==>Press Enter.)

 

Right click your Wi-Fi adapter and go to Properties

 

Click the Power Management tab, and uncheck "Allow the computer to turn off this device to save power"

 

I also went to the Advanced tab and changed the 802.11n Channel width for band 2 to "Auto as 20 MHz Only" was selected.

 

I clicked OK, closed the windows and restarted my PC for good measure. Since then I have not had the issue with the limited connection and dropped connections.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So after wasting a full day, I was finally able to have my connection back! All I did was reset my router. I also downloaded all the latest drivers from both Lenovo(have a Yoga 2 Pro) and Intel website. I'm not an expert in computing but this website also really seemed to help, I followed the instructions about the TCP/IP settings.

http://optimizewindows8.wordpress.com/2013/11/07/how-to-fix-limited-wi-fi-connectivity-issue-in-windows-8-1/

My connection still shows ''limited'' but I can go to internet, run apps, netflix without  problems.

I did all of this and that but nothing works so what it happens is by accident  move from my rental to another rental and whit another IP provider the last one doesn't  have service in this area and new router Linksys 2700 guess what no more limited internet or dropping internet this internet provider is up to 30 bpm    

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That does make a lot of sense since routers play a big part. I find the dual band routers with 5k connections seem to like Windows 8.1 far better the older 2.4 band. Especially with security. Turning off security seems to fix even old equipment like my Roku which was limited to 2.4 band. Look at all the bad reviews of 802.11n equipment on Newegg and see how bad the mess is. For every user that says a product is great another says it is ****. Standards? What Standards?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Simple solution that works for me and passed the rigors of time,

1- Click SETTINGS

2- Side the WI-FI to ON

Also under PC & Devices, which may not be necessary, I set DOWNLOAD OVER METER CONNECTIONS to OFF.

The bottom line is I have Wi-Fi connection to my CANNON PIXMA MX410, where I used the CANNON pushbuttons on the device itself to set the Wi-Fi communication to the NETGEAR ROUTER. The USER NAME and PW supplied by the NETGEAR can be found on the bottom of the device. I also did the same for my SONY BP S580 by using the SONY remote device. If you're missing any instruction manuals, all those downloads are available on the manufacturer's site.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is horrible response and I've seen it given by other MS engineers. Thousands of people are having this problem since the 8.1 release. I highly doubt all of us had our routers go bad at the same time. Own up to this Microsoft and please fix it. The standard response will not cut it anymore.

I couldn't agree more!!  We have four computers in the house and only my BRAND NEW desktop is having this problem since I upgraded to 8.1.  I should have left well enough alone!!  Fix it PLEASE it is REALLY annoying!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.