Q: Windows 8.1 can not detect Nokia N8 with JoikuSpot

Why can't my laptop ASUS K55V with win 8.1 pro w/ media center detect my Nokia N8 running with JoikuSpot Premium as a wifi router?  I have no problem before with this same laptop in win 7.  

What I used to do is run an app "joikuspot" on my N8. This will make my N8 a mobile wifi hotspot.  Then search a wifi connection on my laptop which will detect my N8 and connect to it.  This is before when I am still using windows 7 in this lap top.  But when I tried it again after upgraded to windows 8.1 preview (from windows 7 upgraded to windows 8 pro w/ media center then to windows 8.1 preview) the laptop doesn't detect my N8 as mobile wifi hotspot.  I thought updating to windows 8.1 pro w/ media center will solve this but in didn't.  So at present, this laptop is running at windows 8.1 pro w/ media center with the same problem.

This problem cannot be the N8's problem or the app because I have an ipad2 w/ iOS 6 which i use with no problems.  I also tried my friends laptop running w/ windows 7 ultimate with no problems.  No problem means they can detect and connect to my N8 as a wifi hotspot.

How can I resolve this?



I was having the same issue.
Below is something that I found on the internet which helped me out

 It turns out that Windows 8.1 doesn't show ad-hoc networks and it's by design, and the hotspot created by Joikuspot is an ad-hoc network.

There is a way to manually connect to that network, however. Note, this is NOT about how to create an ad-hoc network to share your Internet connection with another device! It's about how to connect your Windows 8.1 PC to an existing ad-hoc network created on another device.

How to connect to an ad-hoc WiFi network in Windows 8.1.

Because the wireless network picker in Windows 8.1 doesn't show ad-hoc networks, connecting must be done by hand.

To see all networks in range, including ad-hoc, run this command in command shell (cmd.exe):
> netsh wlan show networks


This must be done only once per network.
• go to "Network and Sharing Center"
• click "Set up a new connection or network"
• double click "Manually connect to a wireless network"
• enter the SSID of the ad-hoc network (as shown by "netsh wlan show networks") into the "Network name" field
• configure security settings accordingly
• uncheck "Start this connection automatically" (important)
• click "Next", then "Close"

Run this command (important):
> netsh wlan set profileparameter <ssid> connectiontype=ibss

Replace <ssid> with the SSID of your network.


After setting up, run this command whenever you want to connect:
> netsh wlan connect <ssid>

Replace <ssid> with the SSID of your network.

Hovering over WiFi icon in system tray will show the name of the network that you are currently connected to, even if it's an ad-hoc network (the network picker will not show it if it's ad-hoc). The name is also visible in "Network and Sharing Center" window.


To disconnect from the ad-hoc network: connect to a different network, turn off wifi, or run this command:
> netsh wlan disconnect


To remove the network profile from Windows, run this command:
> netsh wlan delete profile <ssid>

Replace <ssid> with the SSID of your network.

Did this solve your problem?

Sorry this didn't help.

6 people were helped by this reply



This topic was very helpful to me, so here are my two cents worth.

First, do all the steps up to actually connecting.

Then paste "netsh wlan connect JoikuSpot_XXXXXXXXXYYY" ( replacing the exact SSID of your connection of course) in a blank notepad file, save as (ALL files type)  SSID.bat on your desktop.

Run as administrator (right click) any time you wish to connect. That's it


If you want to get fancy, (credit to Evan Greene), paste the following instead, which will automatically run with admin priv:


@echo off
:: BatchGotAdmin (Run as Admin code starts)
REM --> Check for permissions
>nul 2>&1 "%SYSTEMROOT%\system32\cacls.exe" "%SYSTEMROOT%\system32\config\system"
REM --> If error flag set, we do not have admin.
if '%errorlevel%' NEQ '0' (
echo Requesting administrative privileges...
goto UACPrompt
) else ( goto gotAdmin )
echo Set UAC = CreateObject^("Shell.Application"^) > "%temp%\getadmin.vbs"
echo UAC.ShellExecute "%~s0", "", "", "runas", 1 >> "%temp%\getadmin.vbs"
exit /B
if exist "%temp%\getadmin.vbs" ( del "%temp%\getadmin.vbs" )
pushd "%CD%"
CD /D "%~dp0"
:: BatchGotAdmin (Run as Admin code ends)
:: Your codes should start from the following line
netsh wlan connect JoikuSpot_XXXXXXXXXYYY 




Did this solve your problem?

Sorry this didn't help.

Question Info

Views: 23,320 Last updated: March 29, 2018 Applies to: