Windows 8.1 Ad Hoc not showing

Hallo

A friend of mine just updated her Windows 8 to 8.1. 
When she used Win 8 we had no problem with me making af Ad-Hoc network (With Win 7) and her seeing and connecting to it. But after she updatet Windows it wont see Ad-Hoc networks anymore. We have tried making Ad-hoc's on different pc's but her computer cant see any of them?

Does anyone have the same problem, and how do i fix it for her?

Mikkel
 

Question Info


Last updated November 5, 2018 Views 137,885 Applies to:
Answer

Because the wireless network picker in Windows 8.1 doesn't show ad-hoc networks, connecting must be done by hand.

To see all networks in range, including ad-hoc, run this command in command shell (cmd.exe):

> netsh wlan show networks


SETUP

This must be done once per network.

  • go to "Network and Sharing Center"
  • click "Set up a new connection or network"
  • double click "Manually connect to a wireless network"
  • enter the SSID of the ad-hoc network (as shown by "netsh wlan show networks") into the "Network name" field
  • configure security settings accordingly
  • uncheck "Start this connection automatically" (important)
  • click "Next", then "Close"

Run this command (important):

> netsh wlan set profileparameter <ssid> connectiontype=ibss

Replace <ssid> with the SSID of your network.


CONNECT

After setting up, run this command whenever you want to connect:

> netsh wlan connect <ssid>

Replace <ssid> with the SSID of your network.

Hovering over WiFi icon in system tray will show the name of the network that you are currently connected to, even if it's an ad-hoc network (the network picker will not show it if it's ad-hoc). The name is also visible in "Network and Sharing Center" window.


DISCONNECT

To disconnect from the ad-hoc network: connect to a different network, turn off wifi, or run this command:

> netsh wlan disconnect


CLEANUP

To remove the network profile from Windows, run this command:

> netsh wlan delete profile <ssid>

Replace <ssid> with the SSID of your network.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

Hi Mikkel,

 

 

We have found many users complaining about the ad hoc networks not being shown in the wireless network list in Windows 8.1.

 

As a work around, I would suggest you to use the Wireless hosted network and check if that helps you connect both the computers.

 

- In the Search Charms, type command prompt, right click on command prompt and select Run as Administrator.

- Type the following commands and press enter.

 

netsh wlan show drivers

 

note: Check the "Hosted network supported" string. If it is yes, then your wireless network adapter supports hosted network feature. If not, then you will not be able to use it.

 

 

If the string is yes, then follow these steps and check.

 

To setup a hosted network,

 

netsh wlan set hostednetwork mode=allow ssid=”DESIRED_NETWORK_NAME” key=”YOUR_PASSWORD”
 
To Start the Hosted network,
 
netsh.exe wlan start hostednetworkname
 
When you are finished with it, you can stop the connection using this command:
netsh.exe wlan stop hostednetworkname
 
You can get detailed information about the network you started with this command:
netsh wlan show hostednetworkname
 
 
You may even download third party to connect two computers wirelessly.
Disclaimer: Using Third Party Software, including hardware drivers can cause serious problems that may prevent your computer from booting properly. Microsoft cannot guarantee that any problems resulting from the use of Third Party Software can be solved. Using Third Party Software is at your own risk.
 
Hope this information is helpful. If you have any concerns, let us know.
Microsoft Desktop Support Engineer

25 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.