netsh wlan start hostednetwork not working on surface pro 3

I am trying to start the hostednetwork 

netsh wlan set hostednetwork mode=allow ssid=test key=12345678

The hosted network mode has been set to allow.
The SSID of the hosted network has been successfully changed.
The user key passphrase of the hosted network has been successfully changed.

netsh wlan start hostednetwork

The hosted network couldn't be started. 

A device attached to the system is not functioning

I am getting this error , """ The hosted network couldn't be started. A device attached to the system is not functioning """

I never had problem using on my previous dell which ran on windows 8.1, but on surface pro3 i am not able to , 

I tried all the suggestions , like going to device manager restart network adapter and all , 

Please help.

Thank you.

 
Question Info

Last updated July 13, 2018 Views 13,255 Applies to:
Answer

The opening poster is not having problems connecting to wifi.

He/she is having problems sharing their wifi connection via netsh command.

I have exactly the same problem as do many other Surface Pro 3 users.

Microsoft, please issue a fix for this asap.

See below taken from: http://www.surfaceforums.net/threads/anyone-able-to-create-hotspot-on-surface-pro-3.9440/page-2

"So, for the benefit of all, I made the dreaded call to Surface support to see what could be done. After the usual useless resets and other basic troubleshooting were needlessly completed, I was eventually transferred to a technician that knew what she was talking about. She tried to set up a hosted network on her SP3 and ran into the same error message. Nothing she could think of to try made any difference, so there appears to be some sort of compatibility issue with hosted networks and the SP3. I suspect it is a driver problem, but only time will tell.

She will be reporting the case to the next level of Surface support for their evaluation. I will keep everyone posted as I hear back from Microsoft about this issue. However, for now, it appears that we're dead in the water."

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

Hi Bhaskaratumati

 

Welcome to Microsoft Community.

I understand that you are unable to establish a hostednetwork on Surface Pro 3.

 

This must be an issue with hidden networks that is disabled and not allowing you to connect.

 

To assist you better on this issue, I need more information from your end.

  1. Are you trying to create a hotspot connection?
  2. Is your system connected to a domain network?

(If it is not in domain network, we need to make sure that other computers are able to connect to the same network.)

 

Let’s try some basic troubleshooting steps down here to fix it.

 

Step 1.  On the Start screen, swipe in from the right edge of the screen, and then tap Settings.
(If you're using a mouse, point to the lower-right corner of the screen, move the mouse pointer up, and then click Settings.)

Step 2. Tap or click Change PC Settings, and tap or click Control Panel.

Step 3. Tap or click Hardware and Sound, and then tap or click Device Manager.

Step 4:  Go to device manager.

Step 5: Click on view and press on "show hidden devices".

Step 6: Go down to the list of devices and expand the node "Network Devices”.

Step 7: Find an adapter with the name "Microsoft Hosted Network Virtual Adapter" and then right click on it.

Step 8: Select Enable

Step 9: This will enable the AdHoc created connection, it should appear in the network connections in Network and Sharing Center, if the AdHoc network connection is not appear then open elevated command prompt and apply this command " netsh wlan stop hostednetwork " without quotations.

(To open the command prompt type “cmd “ in search option of Start Window and click on it.)

Step 10. After this, the connection should appear.

Hope it can answer all your queries. Do reply us with the update, we will be happy to help.

Thank You

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.