Windows 8.1 WLAN not working after sleep

I am running Windows 8.1 Pro on HP 8510w mobile workstation with Intel WiFi Link 4965AGN wireless module.
After waking the device from standby the WLAN module seems to be unable to create any connection to any access point.
Disabling the device/interface and re-enabling it temporary solves the issue but requires full elevated admin privileges.

I was able to mitigate the issue by disabling 802.11n mode in advanced device properties within the device manager. Usually it re-connects now after waking up from sleep but randomly crashes the complete kernel with STOP 0x0000001d error code (DRIVER_IRQL_NOT_LESS_OR_EQUAL).

I am using Microsoft bult-in driver for the wireless module as Intel does not provide one:
Driver Provider: Microsoft
Driver Date: 15.08.2010
Driver Version: 13.3.0.137

I don't believe Microsoft is willing or able to solve the problem. So this is mainly for archive reasons and to provide the information that disabling 802.11n mode might help partially. Just in case somebody runs into the same issue. Although disabling 802.11n mode is only a work-around with big drawbacks in terms WLAN speed.

Hi Rainer,

 


Thank you for sharing the information with us, this will help to all community members who face similar issues.


The error code, IRQL_NOT_LESS_OR_EQUAL occur due to the following reasons.



o    This bug check is issued if paged memory (or invalid memory) is accessed when the IRQL is too high.

o    The error that generates this bug check usually occurs after the installation of a faulty device driver, system service, or BIOS.

o    If you encounter bug check 0xA while upgrading to a later version of Windows, this error might be caused by a device driver, a system service, a virus scanner, or a backup tool that is included with the new version.



I would suggest you to download and install the latest wireless drives and chipset drivers from the manufactures’ website and check if it helps.



Keep us posted on the status of the issue.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Vijin,

Many thanks for your reply. This is somehow related to the BSOD issue in netwlv64.sys which I have reported here.
I recommend to discuss BSOD issues with this driver over there.

This thread is about the sleep/wakeup issue. Actually both issues might at the end point us to issues with the driver provided by Microsoft or the driver interfaces in the kernel.

So this thread was more for archive if people run into the same problem with Intel 4965AGN WiFi chipset to try disabling 802.11n mode fixing the standby-resume issue.

The BSOD issue is likely fixed by disabling Message Signal Interrupt (MSI) on this driver in registry. At leasts no BSOD any more since then. More details in thread linked above.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I fixed this not-connecting-issue by:


In the device Power Management settings uncheck "Allow the computer to turn off this device to save power". Since i did this, the WiFi is stable.


As described here:

http://how-i-fixed-it.blogspot.de/2013/10/wifi-authentication-issuesfailed-after.html


But there are still issue with the BSOD as reported in other threads. Seems like Microsoft or Intel have to fix the driver.


My blog entry about the BSOD issue linking other threads in forums going on:

http://how-i-fixed-it.blogspot.de/2013/11/blue-screen-of-death-bsod-on-windows-81.html




SI

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I fixed this not-connecting-issue by:


In the device Power Management settings uncheck "Allow the computer to turn off this device to save power". Since i did this, the WiFi is stable.


As described here:

http://how-i-fixed-it.blogspot.de/2013/10/wifi-authentication-issuesfailed-after.html


But there are still issue with the BSOD as reported in other threads. Seems like Microsoft or Intel have to fix the driver.


My blog entry about the BSOD issue linking other threads in forums going on:

http://how-i-fixed-it.blogspot.de/2013/11/blue-screen-of-death-bsod-on-windows-81.html




Yes, workaround and many other discussions described here.
In fact sometimes power management settings are sufficient. Sometimes disabling 802.11n mode is required too and also disabling MSI for the device might be required.

In the thread mentioned above we found outdated driver version 12.4 to work best and most stable. It's actually a driver for Windows Vista but seems to work without frequent BSOD at least.

Still I believe Intel/Microsoft should release a new driver or Microsoft fix the kernel to work with existing drivers, whatever has been changed.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Use NETw4v64.sys version 11.0.5.32. You’ll notice it assigns the wireless adapter a negative IRQ and the blue screens stop coming up. It is available here:

http://support.toshiba.ca/support/isg/drivers/common/vista/Intel%20Wireless%20Driver-11.5.0.32.zip


Chris

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,

 

I would suggest you to check if there is any pending Windows Update needs to be install which may help us to resolve this issue.

 

Try to download and install al the latest chipset drivers and Hardware Driver update from the manufactures’ website.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Surface 3 has the same problem. After each sleep it looses connection to my WLAN (which is 1m aways). Every device I have works. Again MS fails. After more than 25 years with MS, I now have already 3 iPads and I dont see why anyone needs products from MS anymore.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi, 

I had the same issue as above. I found this link below that may help..................Worked on my Lenovo T61.

 https://social.technet.microsoft.com/Forums/windows/en-US/e7d49799-18fa-4b6c-9854-f94c7913c14d/uninstall-microsoft-virtual-wifi-miniport-adapter-permanantly?forum=w7itpronetworking

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated July 24, 2019 Views 7,083 Applies to: