Windows 8.1 Wifi disabled everytime

Hi.

Ever since i updated to Windows 8.1 i started having all sorts of problems regarding my wifi adapter.

 - After booting my notebook, on the login screen from Windows 8.1, i noticed the wifi icon on the left-down side of my screen. The wifi icon appears with a small circle around it, as if it were searching or trying to do something. If i log in to my windows while that icon is displayed, my wifi card appears as disabled and it doesn't matter if i disable the card and reenable it manually, or if i disable through the Hardware manager, windows keeps saying it is disabled. The only solution is to reboot.

 - After waiting for the circle to disappear on the Login scree, i log into Windows and i can search for wifi networks normally but i can only attempt to connect to a network once. If that attempt doesn't succeed, the wifi card is disabled once more. As said before, it doesn't matter what i do, the only solution is to reboot.

 - For some reason, when trying to connect to a network, i manage to successfully connect to it on my phone (Samsung Galaxy S3), but can't connect on my Windows 8.1. Using the same passwords and all, Windows just refuse to connect to it. And once again, after that connection attempt fails, the wifi card is disabled and i have to reboot.

 - Also if i let my notebook go into hibernation, when i wake it up the wifi is disabled once more.

I tried updating my drivers and had to do it by searching through the web since the Windows Hardware Manager Driver Update option never works. Even though i updated all of my drivers, my wifi card still keeps being disabled. Since everything worked fine when i had a Windows 8, and i can sucessfully connect to wifi networks using my phone and all, i assume this is a problem with the Windows 8.1 update.

My Wifi card is:

NIC PCI-E wireless lan 802.11n Realtek RTL8723AE
 

Question Info


Last updated June 26, 2019 Views 5,495 Applies to:
Answer
Answer
Hi Karthik!

Thanks for all your help. Thanks to you I've got to solve my problem but it was not how i expected to be...

Uninstalling the wifi device did not gave me an option to uninstall my driver as well. Don't know why, neither could i find a place to uninstall my driver using the Device Manager. All i could do was to uninstall and re-install the device, but no the driver.

And yes, i am the Administrator of my machine.

However, when i tried following your third step, going to Dell's website (even though my notebook is not a Dell, is an Avell) i found newer drivers to my Realtek card (RTL8723AE).

My driver was from 2008, the driver version was 2008.something... and when i used Device Manager's "Update driver" option, Windows told me my driver was up-to-date. Also did my anti virus Avast, and a software called SlimDrivers that i tried using... none of these could find that mey wi-fi card driver was obsolete.

Then i downloaded the driver from Dell's website, installed and up until now everything is working great. I even attempted switching wifi networks just to see if my card would disable as before and it didn't. So i'm guessing the problem is fixed.

Once again thanks for your help and, if it counts in any way, i just wanted to say that is kind of lame that Windows "Update driver" button on Device Manager isn't able to detect if the driver has an update. It is the "Update driver" button purpose isn't it?

Anyway, thanks for the assist!

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.