SSD parameters are set incorrectly by 8.1 update

For SSD system drives, the   HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WMI\Autologger\ReadyBoot Start value should be "0". After upgrading from Windows 8 to 8.1, the start value for ReadyBoot was changed to “1”.

 

This value is set correctly after Windows Experience Index is run, but it appears WEI was removed from 8.1. So how do I restore to the correct value?

 

Question Info


Last updated November 6, 2018 Views 14,599 Applies to:
Answer

This is a problem for anyone with an SSD updating from Windows 8 to 8.1. Your Prefetch, Superfetch and ReadyBoot parameters will be changed to incorrect settings during the update.

 

Windows Experience Index runs automatically on a clean installation of 8.1, but not on an update installation. This is necessary for setting the parameters correctly.

 

Microsoft unwisely chose to eliminate Windows Experience Index from the 8.1 version. But it is still available from a command prompt.

  1. Open a command prompt
  2. type in "Winsat formal -v" and hit enter
  3. after it finishes, reboot  3 times. After that, your parameters will be set correctly for an SSD.

Thanks to Praz from the OCZ Forum for figuring this out.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.