No Dolby Digital Live option after change to Windows 8.1 .. :( soundcard = Creative X-Fi Surround 5.1 PRO (usb version)

Hi ! 

I upgraded to win 8.1 a couple of days ago hoping that this would give me better ressource handling during Battlefield 4.

I've just uppgraded my headset to a Astro a40 and was amazed of the soundquality and surround under windows 7 ( with Dolby Digital Live enabled ) 

So I had high hopes when uppgrading to win 8.1. But all that was in vain ... 

There is NO way to enable DDL under win 8.1 and Creative has no drivers/programs that work ( because of the bitcode change,, ) 


So here I am, back to regular stereo and no chance of getting DDL to work on my new operating system.  ( I can only choose stereo under speakers ;( ) 

Checked your compatibility page and it says that my soundcard is supported, but just stereo i guess ... :( 


Any hopes of getting Dolby Digital Live to work again ? 

Best regards 

Espen H
 

Question Info


Last updated March 25, 2018 Views 3,492 Applies to:

 

Hi Espen,

 

I would like to know this information regarding the issue:

 

 What is the current version of the Creative X-Fi Surround 5.1 PRO sound card driver that you have installed on the computer? Is it the Windows 8 compatible version: 1.02.0061?

 

If not I would recommend you to install this latest version from this link:

 

Creative Sound Blaster X-Fi Surround 5.1 Pro Driver 1.02.0061

 

If that doesn’t work, then you may try installing this driver in Windows 8 compatibility mode and check if that resolves the issue. To install a driver/an application in its compatibility mode, please refer to this article:

 

Get your apps and devices working in Windows 8

 

For more information about Program Compatibility, you may also refer to these links:

 

What is program compatibility?

 

Program Compatibility Assistant: Frequently asked questions:

 

Hope this is helpful. Please get back to us with the results.

Regards,
Rajesh Govind - Microsoft Support Engineer

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I can select dolby digital live in win 8.1 but the audio cuts out every second or so, so it is not working. it worked fine in win 8...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi ! 

I upgraded to win 8.1 a couple of days ago hoping that this would give me better ressource handling during Battlefield 4.

I've just uppgraded my headset to a Astro a40 and was amazed of the soundquality and surround under windows 7 ( with Dolby Digital Live enabled ) 

So I had high hopes when uppgrading to win 8.1. But all that was in vain ... 

There is NO way to enable DDL under win 8.1 and Creative has no drivers/programs that work ( because of the bitcode change,, ) 


So here I am, back to regular stereo and no chance of getting DDL to work on my new operating system.  ( I can only choose stereo under speakers ;( ) 

Checked your compatibility page and it says that my soundcard is supported, but just stereo i guess ... :( 


Any hopes of getting Dolby Digital Live to work again ? 

Best regards 

Espen H
hey if you still have win 8.1 installed can you install the driver from the CD not the web. supposedly the dolby digital live is only on the CD and is not included on the web drivers. thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I can select dolby digital live in win 8.1 but the audio cuts out every second or so, so it is not working. it worked fine in win 8...


Hi Franco,

1) Does the issue (mentioned above) happens even after installing the latest Creative Sound Blaster X-Fi Surround 5.1 Pro Driver, version: 1.02.0061(Only if you are using the same sound card)?
2) If yes, did you try it in its compatibility mode?
Regards,
Rajesh Govind - Microsoft Support Engineer

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

yes and yes.


I have reformatted and reinstalled win 8 and it is now working perfectly

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm having the same issue as Franco.  I updated Windows 8 Pro to 8.1 last night.  A little about mysetup: 

I also have the Soundblaster X-fi Pro usb sound card, it is plugged into a set of Logitech 5.1 speakers through the analog outputs, then I also use the optical output to connect to my Turtlebeach Earforce DSS (digital decoder), which is connected to my Turtlebeach headset.  So I can disable either one to use either the speakers or the headset, though I mainly use the headset.  The sound card is set to output Dolby Digital Live through the optical cable, so I can get surround sound on my headset.

This setup worked with no issues on Vista, then with no issues on Windows 8 Pro when I built a new PC.

After the update, I had no sound at all in the headset, but I found that the update had apparently reset some settings.  So I tried setting the Dolby Digital Live up again, but I am having all kinds of audio issues.  When I go to "playback devices" and try to play test sounds, the sounds play but they cut out and distort, sometimes they sound like they have some static (crackle and pops).  Normally the lights on the DSS change to "DD" when Dolby Digital is playing, but now the lights flicker back and forth between digital and analog rapidly while trying to play the test sounds.  When I try playing a youtube video or a game, the same thing happens, the lights on the DDS flicker and the sound cuts in and out.

I tried updating to the Creative Sound Blaster X-Fi Surround 5.1 Pro Driver 1.02.0061 drivers several times, also tried running the driver installer in compatibility mode for windows 8.  I also have the original CD for the hardware too, so I tried uninstalling everything related to the sound card and re-installing all the original software. I also tried running the installer on the CD in compatibility mode.

Any other ideas?  It is kind a pain to wipe everything and go back to Windows 8.  I wish I read about this before I installed 8.1.  I'm not sure what they changed from 8 to 8.1 that is causing Dolby Digital Live so much hassle.  I thought it was a pretty minor upgrade.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey bud, I actually signed up for this just so I could tell you how to fix it since I was having the EXACT same problem..  first go to the creative audio control pannel, click the encoder tab, then click check the box for dolby digital live and presto! the light should light up just fine then.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I can select dolby digital live in win 8.1 but the audio cuts out every second or so, so it is not working. it worked fine in win 8...

I have the same issue sadly, I can make the DD live work with installing with CD and updating it with the last driver, but no matter what I try, the sound cut and crack all the time...

I am on windows 8.1 too.

The issue with Sound Blaster drivers and Windows 8.1 is well known, but creative doesn't seems to put a priority on fixing it.

I really hope someone will come up with a solution...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

this problem seems to be fixed with the drivers from feb

http://support.creative.com/KB/showarticle.aspx?sid=61105&h=13

I get crackling when there is no sound playing but it goes away when there is sound playing

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.