"Network password" needed to link to Seagate GoFlex storage device

For two years I've had two Windows 7 computers linked to a Seagate GoFlex backup storage device.  The computers connect to the router wirelessly and the GoFlex connects to the router by Ethernet.  Backups have been working well. 


I'm now replacing one of the Windows 7 machines with a Windows 8 machine.  The Windows 8 machine also connects to the router wirelessly.   In the Network view, I can see the GoFlex attached to the router, but when I double click on it I receive a Windows message that I need to enter the Network Password.  Apparently because of this, the Seagate Desktop software can't connect to the GoFlex and the Memeo backup software supplied by Seagate also can't see the GoFlex.  (The Seagate Desktop and Memeo software connect to the GoFlex perfectly from the Windows 7 computers.)  I upgraded from Windows 8 to 8.1 and I have the same problem with the need to enter a Network Password in both versions of Windows 8.


Perhaps there is a Seagate connection problem as well, but the first issue to resolve seems to be that Windows 8/8.1 needs a Network Password.  I've tried my new Windows 8 user name and password, my router name and password and my HomeGroup name and password.  I've even tried my Seagate user name and password, but this seems unlikely since the pop-up is Windows generated.


I updated the Seagate Dashboard to the new version that works with Windows 8 -- but the fundamental issue seems to be that Windows 8 needs a network password but it won't tell me which network password to use.


I'm guessing there is a new security setting in Windows 8 compared with Windows 7.  (I generally use the default security settings.)


Would someone know what network password I'm supposed to supply or what security setting I need to change in Windows 8.1?


Hi Mark,

Thanks for the update. Since this issue is related to Seagate GoFlex storage device. I would suggest you to contact their Support Site for better assistance. You may refer these links and check if it helps.



Thanks and regards,

John Rubdy
Forum Moderator | Microsoft Community

6 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated April 27, 2021 Views 8,647 Applies to: