Having problems with your Logitech Dual Action Gamepad (controller) in Windows 8.1?

I upgraded to Windows 8.1 and my Logitech profiler stopped being able to detect my Logitech Dual Action Gamepad (controller). The hardware was still detected and some information was passed through, but the Logitech Profiler is so useful that I had to get it up and going.

Knowing my own frustration - I thought I would pass the fix along to the Gaming Community. (Let's face it, the Logitech Dual Action Controller rocks and Logitech should never have discontinued it's production)

Microsoft compatibility list was unable to make the Logitech Profiler function correctly.

I, however, was able to find a fix.

1) go to www.logitech.com
2) Hover over "Support" and pull down
3) Select "Support + Download"
4) Select "Gaming"
5) Scroll to the bottom and click on "Dual Action Gamepad"
6) Click on Downloads
7) Pick OS as "Windows 8"
8) Pick 32-bit or 64-bit dependent upon your system (my system is 64-bit)
9) Hit the "Download Software" and save it to the Desktop or you Download folder
10) Open Control Panel
11) Under "Programs", click uninstall programs.
12) Look for "Logitech Gaming Software" (may have a slightly different name) and click uninstall
13) NOTE :: this does not uninstall the Profiles in your Logitech folder. I do, however, suggest that you always use the profiler to export copies of any game profiles that you create as back-up or in case you want to share them with others.
14) Go to the Download from Logitech - labeled "lgs510_x64" if you downloaded the 64-bit version - and run the file to install the profiler.
15) Follow the set-up procedures and your Logitech Dual Action game pad should once again work as it did under Windows 8.1

At this  point, the Logitech Profiler opened up with no problem (aka it was able to detect the controller). You should still have access to all your profiles.

In my case, it had even loaded up the profile and settings that I had used last.

And, if you have been having problems getting keyboard/mouse games to accept the controller input, the fix is to

1) Open the Profiler

2) Click on "Options"

3) Click on "Global Profiler Settings"

4) Click "Apply Persistent Profile"

5) Select the Game that you want to play. (You will have to change this as you change games aka Profiler configurations)

At this point, the computer sees the Logitech Controller input the same as it would the keyboard and mouse.

NOTE :: While you have the controller set to "Persistent Profile" the controller will generate input your computer based on those settings even when you are not playing a game.

This means that if your computer starts acting squirrely make sure that your controller isn't turned sideways forcing a joystick out of neutral or whatnot.

I put my controller where it won't fall over or otherwise fiddled with. 

You can all always turn the settings on and off if it is an issue or simply unplug the controller while you aren't gaming. I leave mine plugged in and have only knocked over my controller and caused an issue a time or two.

Good luck and good gaming!

 

Question Info


Last updated September 7, 2018 Views 10,446 Applies to:
Answer

Hi,

We appreciate your efforts in sharing this workaround with us. This would be helpful to other users facing similar issues. Feel free to use this forum if you have any Windows related queries or if you want to share any useful information in the future.

Have a great day!

Cheers,
Ben.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.