Japanese language not displaying properly in some installed programs in Windows 8

<Original title: Japanese language not properly displayed in some installed programs in Windows 8>

Hi

I have just installed Windows 8, the default language of the DVD is UK English.

I need to work with Japanese language, so after installing windows I downloaded and installed the Japanese language pack.

Windows is correctly displayed in Japanese, however some programs show garbled text when I try to install (I tried to install anyway, but the program text was also garbled)

Some programs are correctly displayed in Japanese (e.g. CoreTemp or Hidemaru, a Japanese text editor) some are not (like Lhaplus, above screenshot, this is a Japanese program which default language is Japanese)

I was using an English language versions of Windows 7 before, and never had this issue.

If anyone has an idea how to fix this, I'll highly appreciate.

Thank you !

 

Question Info


Last updated June 8, 2018 Views 1,594 Applies to:
Answer

Hello Oliver,

Welcome to Microsoft Community Forum.

As per the description, I understand that you are facing issue with Japanese language pack. I will certainly help you with this issue.

This issue can be caused due to incorrect language pack settings. Let’s work together to get this problem resolved.

I would suggest you to try the following methods:

Method 1:

Follow the steps mentioned below in the Microsoft article.

Change your language or keyboard

http://windows.microsoft.com/en-US/windows-8/using-multiple-languages

Please refer to these following sections and check it helps:

  • Set a language as your primary language.
  • Add a keyboard layout or input method for a language.
  • Change the default keyboard layout or input method.

If the issue still persists, then try method 2.

Method 2:

Try the change the software’s non-Unicode settings:

1. Press the Windows key + X and click on Control Panel.

2. Click on Clock, Language, and Region.

3. Click on Region.

4. Click on Change keyboards or other input methods of the Regional and Language.

5. Click on Administrative tab.

6. Click on Change System Locale button under the section of Language for non-Unicode programs.

7. Click on the Drop down menu and then select Japanese.

8. Restart your computer and check if it helps.

You may also refer to this Microsoft article:

Language packs are available for Windows 8 and for Windows RT

https://support.microsoft.com/kb/2607607

Refer to the section: How to change the display language of pre-installed Windows Store apps.

Hope the information helps. Let us know if you need further assistance with Windows related issues, we’ll be glad to assist you.

Thank you

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.