How to disable charm bar

Original Title: How do I turn off that annoying right side 'taskbar' and pop up date and time square that interrupts what I am doing if I mouse too far to the right?

I hate the right side pop out thing and the pop up date time thing that happens when I mouse too far to the right on my display.  How do i make it go away?? <Removed PII>

 

Question Info


Last updated February 12, 2019 Views 12,064 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Les,

It seems that you want to disable charms bar which appears on the right-hand side of the screen when you move your mouse to either the upper or lower right corner on your Windows 8.1 computer. I understand that charms Bar can also be quite distracting at times, especially when you shake it up every time you move the cursor over close button in an opened window.

Please follow the steps mentioned below:

Step 1: Disable Charms Bar in Windows 8.1 via Taskbar Properties:

The Taskbar and Navigation Properties window is the quickest way to disable the Charms Bar.

1. Right-click Taskbar followed by clicking Properties in the context menu.

2. Then click the Navigation tab.

3. Now, under the Corner navigation section, simply uncheck ‘When I point to the upper-right corner, show the charms’ option and hit OK.

4. This will disable it from the top right corner only, which means moving the cursor to the bottom right corner will still display the Charms Bar.

To get rid of it from lower corner as well, you can use ImmersiveShell key in Registry Editor.

Step 2: Disable Charms Bar in Windows 8.1 from Registry Editor:

Important: The below contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.

For more information about how to back up and restore the registry, follow the steps from the following link: http://support.microsoft.com/kb/322756/en-us

1. First up, open Registry Editor by heading to Start Screen, typing regedit and pressing Enter on your keyboard.

2. Now navigate to the following registry key in Registry Editor:

HKEY_CURRENT_USER>Software>Microsoft>Windows>CurrentVersion>ImmersiveShell

3. Now go to ImmersiveShell > New > Key from the context menu, and then name the new Key as EdgeUI.

4. Right-click the EdgeUI key, point to New, DWORD (32-bit) Value and then name the new DWORD as DisableCharmsHint.

5. Now double-click the newly created DWORD value, type 1 and click OK. You may also need to reboot Windows for the changes to come into effect.

Once done, it will disable both the top-right and bottom-right hot corners that reveal the Charms Bar.

Please reply us on the status of the issue to assist you further.

Thanks,
Yaqub Khan

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.


This sort of annoying 'charm' that you can barely turn off without having a technology degree is exactly why windows 8 is the worst version yet. Why on earth can't there be a simple, 'turn if off completely' option?

28 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It's easy to turn off for IT administrators (or also anyone using Pro edition as an 'added value' reason to get the pro version).  Just remember that without it you can't get to settings for many functions, or project your screen to a projector, or share your screen to your TV console.
Shawn "Cmdr" Keene | Microsoft MVP - Windows Insider | CmdrKeene.com | tweet me: @LtCmdrKeene
Microsoft MVPs are independent experts offering real-world answers. Learn more at mvp.microsoft.com.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

How many people worldwide buy laptops for their homes where there is no IT Administrator?

The answer is Hundreds of millions of users. So all of these home users are affected by this annoying "charm" and need to know how to get rid of it.  It should never have been enabled in the first place for laptops.

What member of Mensa in Microsoft decided to enable this as the default? Is somebody deliberately trying to sabotage Microsoft?

Everybody I know who has this version of Windows is totally irritated by this so-called "charm".

Why would anybody want to have this screen popup every time they move the cursor from right to left? They then have to click on the page they want to use to get rid of this completely unnecessary set of screens. This can happen hundreds of times in one evening.

I know somebody who got a new new laptop a year ago and in all that time this useless pop-up has appeared tens of thousands of times. When I asked her how many times she actually used this "charm", her answer was zero times - that 0 out of 1,000s. That is how intelligent this default is.

This "charm" has to be one of the most annoying and irritating "features" since the last long line of irrational defaults that have been "enhanced" into previously working Microsoft products.

Other mindless "enhancements" that have been made by Microsoft to previously properly working software products include:

- Outlook mail search - this defaults to only search the current folder. It has to be manually set to search all sub-folders every time that you initiate a search.

This search facility used to work well before the "enhancement" was inflicted on Outlook. It used to stay set to the value used in the last search. That way you could leave it set to search all sub-folders every time, which is what you would expect to be the default requirement in 99.999999% of searches! There is a setting in Outlook Options that looks like it should allow a user to set this to search all folders, but like a lot of MS software it does not work.

- MS Project - The Default is now set to Manually Schedule.  Why would anybody in his/her right mind select manually schedule as the default and still use this tool?

The whole point of using MS Project is to automatically schedule tasks.

This is another example of an insane Microsoft default setting.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Could you just create a regedit patch that people could download to their desktops and execute to fix this regedit problem? By the way this regedit fix does not get rid of the charms bar from the lower right corner

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

These should help :

How to disable Charms Bar completely in Windows 8.1 <-- offers a Charms Bar Killer
App which I have not tried.
http://winaero.com/blog/how-to-disable-charms-bar-completely-in-windows-8-1/

How To Disable Charms Bar In Windows 8.1
http://www.techattend.com/disable-charms-bar-in-windows-8-1/

How to Disable Hot Corners (Charms Bar and App Switch List) in Windows 8.1?
http://www.askvg.com/how-to-disable-hot-corners-charms-bar-and-app-switch-list-in-windows-8-1/

Eliminate Accidentally Hitting Charms Bar
http://social.technet.microsoft.com/Forums/windows/en-US/1e24be7e-c2d8-4250-90c5-1f1e7f4f1e92/eliminate-accidentally-hitting-charms-bar?forum=w8itprogeneral

How to Disable Charms Bar and Program Switcher in Windows 8
http://teamwindows8.com/2013/02/how-to-disable-charms-bar-and-program-switcher-in-windows-8/

Hope this helps.

Rob Brown - Microsoft MVP <- profile - Windows Expert - Consumer : Bicycle - Mark Twain said it right.


Rob Brown - Microsoft MVP - Windows and Devices for IT 2010 - current
Windows Insider MVP 2016 - current

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

HI I tried same thing on server 2012 r2 but not working DisableCharnsHint. especially I want to get rid of search charm because Remote Desktop Users are able to searching everything in RDS Session Hosts.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You can disable search in your group policy settings, will apply to the charms as well.
Shawn "Cmdr" Keene | Microsoft MVP - Windows Insider | CmdrKeene.com | tweet me: @LtCmdrKeene
Microsoft MVPs are independent experts offering real-world answers. Learn more at mvp.microsoft.com.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I cant stop Searching. I tried all search policy. Please Can you say which policy disable searching on the Seacrh Charm. I must to say, I updated All policy with newest.

Thanks in advance.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just like the "helping dog" in Office 95. In my time as IT manager I deinstalled this option quite some times.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.