4K monitor connected through DisplayPort 1.2 and MST

I have a Dell UP2414Q 4K monitor.  If I want to display 3840x2160 @ 60Hz, it uses the MST mode of DisplayPort 1.2 giving me two 1920x2160 tiles on the monitor.  After a lot of poking around, I found that this is the expected behaviour.  One solution is using Intel HD 4600 driver's collage mode, akin to AMD Eyefinity, except that it is extremely limited and this mode does not support spanning a subset of your monitors.  So, you end up with windows thinking there are two portrait monitors beside each other as two separate monitors would look. This causes Windows Store apps only use half of the screen and when you maximise a window it will only maximise to half of the screen. 

It is a workable solution if you consider screen split into two sides a feature, except for the fact that Windows 8.1 guess the DPI incorrectly, causing a resize of windows when moved onto the monitor.  It is especially noticeable in IE 11 where the contents of the browser shrink significantly.

How does Windows guess what dpi setting should be used for a display?  How do I convince Windows to use a different value?

Also, if you change the monitor to run in DisplayPort 1.1 using SST mode, it displays 3840x2160 @ 30Hz, and Windows correctly guesses the DPI setting of the monitor.

Blair.

 
 

Question Info


Last updated January 7, 2019 Views 5,924 Applies to:

Hi Blair,

Windows 8.1 has DPI auto scaling which make some of the applications that is not DPI aware look a little fuzzy and blurry.

I would suggest you to refer to these blogs for more information on the DPI scaling issues with Windows 8.1
Windows 8.1 DPI Scaling Enhancements
http://blogs.windows.com/windows/b/extremewindows/archive/2013/07/15/windows-8-1-dpi-scaling-enhancements.aspx

Hope this information helps. If you have further queries, please reply, we will be happy to assist you.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Rajith,

The problem I am having is with DPI auto scaling.  The monitor has the density of 185 dpi.  The monitor in landscape looks like two 1920x2160 portrait monitors to Windows. Windows mistakenly chooses 100% when it should be choosing 200%.  So when I open or drag windows onto the monitor they are very very small.

4K monitors today are built like this, to run at 60 Hz, it needs to look like two displays to Windows to get enough bandwidth through the DisplayPort cable.  Windows does not allow me to select two displays and make one virtual display.  AMD and Nvidia drivers make up this deficit in Windows by allowing you to span the two panels and present it as one display to Windows.  Intel's drivers do not.

Fortunately, my laptop has a high-dpi screen as well, so I was able to turn off DPI auto scaling and, except for Internet Explorer, it works.  I do not know how to turn off this feature in IE.

Any thoughts on how to tell Windows to use 200% on my monitor instead of 100%?

Blair.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Blair,

could you find a solution with the Dell UP2414Q concerning 4K in 60Hz with the new Microsoft Surface 2 Pro firmware update dtd 11.03.2014?

Thanks

Michael

Michael Coelsch

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

could you find a solution with the Dell UP2414Q concerning 4K in 60Hz with the new Microsoft Surface 2 Pro firmware update dtd 11.03.2014?

Michael,

I don't own a Surface 2 Pro although I doubt anything has changed.

I have been talking with Intel support, and it doesn't look good.  So far they have acknowledged that this cannot be done using their collage feature to create one display out of the two tiles with only 2 out of 3 displays.

I am thinking that Windows uses the horizontal resolution (1920) and the monitor size to figure out what scaling to use. So either the Intel driver is passing the wrong information, or Windows heuristics are incorrect.

Blair.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The GPU driver is supposed to report only one monitor to Windows. This happens on nVidia GPUs and everything works perfectly with MST as there is only one 3840x2160 screen.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The GPU driver is supposed to report only one monitor to Windows. This happens on nVidia GPUs and everything works perfectly with MST as there is only one 3840x2160 screen.

That is a feature of AMD and NVidia drivers, but alas not a feature of Intel drivers.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Extremely frustrating.   I have a very high end 4k monitor, another 4k monitor as well but that one only operates at 30 hz.  Have collage working well (finally) on the high end to run at 60hz.  But I can't use only that monitor and use my other monitor as an additional display.

Intel graphics drivers are very poor.  I've had thius running perfectly on a Macbook pro running bootcamp/windows 8.1  It's a problem with the intel drivers

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The Windows 8.1 DPI auto scaling is worse than useless!

If you have a 1920x1080 monitor and a 3840x2160 monitor, then items on the 4K monitor are too small to read and items on the 1080p monitor are far too big.

If any developers at Microsoft have this setup, they would immediately realize that this is unworkable!

I cannot even adjust to ANY resolution other than 1080p that makes this workable.

What is needed is DPI settings PER SCREEN! If you uncheck "Let me choose one scaling level for all my displays" then you should be able to adjust each screens DPI separately.

Are you telling us that there is no registry setting that we can use to make this workable?

My 4K monitor is wasted because I have to use 1080p resolution at the moment and I want MORE screen real estate.

Please advise what to do!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is a "Give em the run around answer" The word is windows has an issue with displayport running at UHD.

Hi Blair,

Windows 8.1 has DPI auto scaling which make some of the applications that is not DPI aware look a little fuzzy and blurry.

I would suggest you to refer to these blogs for more information on the DPI scaling issues with Windows 8.1
Windows 8.1 DPI Scaling Enhancements
http://blogs.windows.com/windows/b/extremewindows/archive/2013/07/15/windows-8-1-dpi-scaling-enhancements.aspx

Hope this information helps. If you have further queries, please reply, we will be happy to assist you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.