[SOLVED] How can I get 'Change high DPI settings' to work?

===== SOLUTION =====

Go ahead and read my problem statement, but look at my second post to see the solution.

=====

Applications (a game in this case) have Property sheets.

"Properties" > _/Compatibility\_ > --Settings-- > [Change high DPI settings] opens a secondary dialog with the following controls:

Program DPI
[_] Use this setting...
[I signed in to Windows]
[I open this program]

High DPI scaling override
[_] Override high DPI...
[Application]
[System]
[System (Enhanced)]

I've tried all 12 combinations. They appear to do nothing.

I think these Property settings are meant to control graphic scaling, useful for high DPI systems. My laptop has a 3840x2160 display.

Can anyone tell me how to get 'Change high DPI settings' to work?

Warm Regards,

Mark.

 

Question Info


Last updated September 17, 2018 Views 76 Applies to:

What games or software are you trying to use this option with ? What is not working when you use the option ?

- I haven't used an UHD monitor but with my  1080 & 1440p monitors this setting is generally only needed with older games

that use low resolutions that are native to 4:3 aspect ratio such as 1024x768.

When this option is not enabled these games display low and to the right. Enabling it centres them properly.

- An interesting glitch in this system is Win10 often sets this option automatically when you run games that don't need it,

but manages to miss many (most ? ) games that do.

- I have also found it useful with some display Windows such as the profiling software for my Logitech peripherals, but

rather than use the default Application option, I need to use the System option.

In this case I used this setting to make the Window larger and easier to read on the 1440p monitor.

- I have never enabled the 'new' Program DPI option that came with the 1803 update.


- If you also need to make Desktop icons, etc larger you can use the Advanced Scaling Settings in Display .

With my 1440p monitor I am using 130%, but you may need up to 150%. Don't start too high as the size ramps up fairly quickly.

(Note that the percentage that shows in the main Display Window is not the same as what you set in Advanced Scaling Settings)

- I also use the small program below to fine tune my font sizes.

System Font Size Changer - Increase Text Size in Windows 10

- This article concerns connecting an external display but may still have something that applies to your machine ? .... 

Windows scaling issues for high-DPI devices


[EDIT: Regarding post below...

"That should be totally unneeded. Windows scales text and pictures just fine based on the single, percent setting."

- Whatever suits you, but I don't find Windows defaults suitable for my needs, and thought you may find the tool useful.

However, next month the1809 version update will be out, and (Due to popular demand)  MS are adding a font size slider to the Display settings.

Still not as flexible as the 3rd party tool though.

"Here's where you need to listen up"

- No, I don't need to listen up. Where did I even mention Intel HD in my post ? I am fully aware of the differences between

Intel HD and Nvidia gpu's, and no I would not ... "You may ask: "Why not use the Intel GPU for everything?"... ]

.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, and thanks for replying. First, I solved the problem. The problem turns out to be caused by a combination of poor function integration/poor computer architecture by Microsoft, and poor documentation/missing documentation by Intel. Broadly, the problem is created by NMP (not my problem) on the part of Microsoft, Intel, and NVIDIA.

... I haven't used an UHD monitor but ... I have never enabled the 'new' Program DPI option that came with the 1803 update ...

Well,  you may need to do this in the future, so listen up!

... What is not working when you use the option ? ...

My laptop has 2 GPUs (graphics processor units): an Intel HD 530 & an NVIDIA GTX 980M. The game is running on the NVIDIA. The native game resolution seems to be 1280x720 (that's 16:9 aspect) -- it's hard to tell, but I think that's native. At fullscreen, the game is centered but not scaled up to 3840x2160. As a result of not being scaled up, the mouse pointer is too small to see and as a result of that, the game is unplayable.

I can enlarge the game image to 3840x2160 within the game, and it does fill the screen, but the mouse pointer remains its original size and so, is too small to see, especially against a "busy" background -- also, the mouse pointer has about 50% transparency, so that contributes to the problem.

The best solution is to run the game at 1280x720 and have Windows scale it (and the mouse pointer) up to 3840x2160.

The Windows 'Change high DPI settings' settings have absolutely no effect, so I couldn't hack trial solutions.

... With my 1440p monitor I am using 130%, but you may need up to 150%. Don't start too high as the size ramps up fairly quickly. ...

For a 3840x2160 display, Windows recommends 250%. I'm using 200%. Windows is fine. It's game scaling that's the problem. It's the game scaling problem that's caused by NMP.

... I also use the small program below to fine tune my font sizes.

System Font Size Changer - Increase Text Size in Windows 10. ...

That should be totally unneeded. Windows scales text and pictures just fine based on the single, percent setting.

...This article concerns connecting an external display but may still have something that applies to your machine ? .... 

Windows scaling issues for high-DPI devices   ...

Here's where you need to listen up. The integrated display (such as in a laptop) and external displays are handled completely differently. It turns out, the Intel GPU handles the integrated display, even for applications and games that run on the NVIDIA GPU, while the NVIDIA GPU handles the external display. The Intel GPU scales one while the NVIDIA GPU scales the other -- that's poor computer architecture.

You may ask: "Why not use the Intel GPU for everything?" The Intel GPU has 5 (or maybe 8) graphic cores. The NVIDIA GPU has 1536 graphic cores and a much higher clock.

Here's the payoff: Regardless of which GPU renders the window or game images, it's the Intel GPU that scales them and displays them on the integrated display (that is, that displays the graphic memory). But the Intel functions are very poorly documented, they are not intuitive (because the rendering is being done the NVIDIA), and Intel provides no support except for it's NUC computer.

Why would I look at the Intel setup when the game (and almost everything else) is running on the NVIDIA? That, I now know, is a rhetorical question.

Intel provides these settings:

  • Maintain Display Scaling
  • Maintain Aspect Ratio
  • Scale Full Screen
  • Center Image

The help: "Select the screen scaling from the list." DUH?! That's it. No other help. No Intel support. Call them. They'll tell you to go away.

PS: Those Intel settings? They're radio buttons... You can select ONLY one. Which one should you select? Well... Experiment.

PPS: I've thought of an appropriate computer-architecture scenario: Windows is using the NVIDIA GPU as a graphics coprocessor, but it's then using the Intel GPU as the integrated display driver hardware. I suppose a Windows developer would say, "Of course. What else would work?" And I suppose that's right, but no one is documenting how this all works. They are all into NMP. Just read the Microsoft documentation. It's all about multiple displays. This (scaling) is much more than a multiple-display problem.

-----
Acer Predator 17 (3840x2160), Core i7 @ 3.4GHz + 32GB DDR4, 1TB SSD RAID0, NVIDIA GeForce GTX-980M + 8GB GDDR5

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.