Frame rates may drop on some DirectX 9 games at high fps (>120fps) after installing Windows 10 Fall Creators Update

Since installing the Windows 10 Fall Creators Update, the average frame rate of my DirectX 9 game has dropped when I play at high frame rates (e.g. > 120 fps) in full-screen mode. Is there something I can do to fix this?
 

Question Info


Last updated October 15, 2018 Views 10,622 Applies to:
Answer

Hi,

Microsoft is aware of isolated instances of performance impact to frame rates of some apps that utilize DirectX 9 and is working to resolve this in a future Windows Update. This post will be updated once the Windows Update solution is available.

In the meantime, you can work around this by disabling fullscreen optimization for the affected app, or by running the game in windowed mode. To disable fullscreen optimization:

1. From the Start Menu, right-click the affected app and select More > Open File Location. File Explorer will open to the app’s location.

2. In File Explorer, right-click the app and select Properties.

3. On the Compatibility tab, check the box to Disable fullscreen optimizations.

Regards.

15 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.