[FIXED]Forza Horizon 4 shows blinking artifacts at daytime (Windows 10 1903 only)

UPDATE:

It' fixed for me after updating the game to version 1.313.159.2.HV (aka LEGO update)

ORIGINAL STORY:

In Windows 10 1903 build 18362, the game shows blinking elements, like car panel and headlights.

Tested with Nvidia drivers 419.67 and 430.00

Video showing the issue:

Forza Horizon 4 blinking issue in Windows 10 1903 build 18362

 

It didn't happen in Windows 10 1809 with the same 419.67 drivers.

I've posted it here cause I don't know if it's to be fixed by Turn10 or Microsoft (as a recent issue related to BattlEye had to be fixed by game developers).

Has anyone faced it? I didn't find anyone reporting it...

UPDATE 1:

The blinking artifacts only happen in daytime

UPDATE 2:

After having used DDU to uninstall NVIDIA drivers, and installing the latest GeForce (Hotfix) Driver 430.53, I've just found out what triggers the problem: it's GeForce Experience Share Overlay.

As a side note, this problem doesn't happen in Windows 10 1809 with 419.67 drivers, but happens in Windows 1903 build 18362.

As a workaround, to play without the blinking, keep IN-GAME OVERLAY setting disabled while launching the game. You can enable it after the game has reached the screen that says "2018 Microsoft Corporation. All rights reserved" (first screen right after the splash screen). Just be warned that shadowplay recordings will be in desktop mode when doing this, as fullscreen capture requires game is launched with overlay enabled (what will cause the blinking in Windows 1903 build 18362)

I just wonder if this topic shouldn't be moved to Gaming on Windows Insider, as it's specific to an insider build (that will eventually be RTM)....

***Moved from: Gaming on Insider Preview***

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi alb3530,

Thank you for coming by to the Xbox forums. Normally, artifacts or distorted video is due to a change within the graphics card drivers and you did mention that this happened after updating your Windows system. What happened is probably the Windows update automatically updated your graphics card drivers and caused this issue. Maybe re-installing the drivers through the device manager will help but you may also have to download any updates through Nvidia.

I recommend also posting this same issue over on the Forza Forums and Forza subreddit if any other users have the same graphics card as you having the same issues after a system update.

I'd definitely look into your graphics cards and if there is anyway to maybe revert the graphics card update.

Best Wishes,
Diego
Xbox Forums Support

(๑ˆ◡ˆ๑)ノ

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thank you for your reply, Diego!

I've updated the topic with clearer information.

To short, the problem doesn't happen in Windows 10 1809 with Nvidia 419.67 drivers, but happens in Windows 10 1903 with the same 419.67 drivers. After manually updating the drivers to 430.00, the problem continues.

I posted the issue in both Forza Community Support Forums, and Reddit, but no one confirmed if the problem also happened to them.

Can someone confirm if the game works fine in Windows 1903, and if yes, with what Nvidia drivers?

Thank you

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

The risk of being an early adopter, eh!  I won't be doing the 1903 update until it's official public release, and I only have the

Forza Horizon 4 demo to compare with, but....

There would be a lot more processing going on when driving than in your static shots. Is the problem worse while driving ?

- Do you have another current game that puts an equivalent amount of stress on the system as Forza 4 that has a similar issue,

or is the problem only in Forza 4 ?

- Laptop or desktop machine ? Which Nvidia gpu, and what brand and model cpu ?

- Did you change any settings in the game, GF Experience, Nvidia Control Panel, or Windows Display around the time of the 1903 update ?

- Gpu and cpu temps are good (GPU-z also has a cpu temp sensor now) ?  - GPU-Z Video card GPU Information Utility

- Have you tried the Windows Insider Program forum (Categories at top of this page) ? Someone there may have more

details regarding issues with the 1903 update ?

- Nvidia 430 driver ? I see 425.31 . Released 11 April. The driver Nvidia release after the general release of Win10 v1903 may

have any fixes necessary for issues introduced by 1903 ? I'm still using 419.35, but I always update the driver after doing a version update.

.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

"The risk of being an early adopter, eh!  I won't be doing the 1903 update until it's official public release, and I only have the

Forza Horizon 4 demo to compare with, but...."

I didn't tried the demo.

"- Did you change any settings in the game, GF Experience, Nvidia Control Panel, or Windows Display around the time of the 1903 update ?"

I haven't changed any setting in game, Nvidia CPL, and Windows after updating the OS from 1803. Of course after the problem:

-I've updated the driver to 430.00 as a clean installation, that resets all settings.

-I've reduced resolution to 1280 x 720 (monitor resolution is 2560x1440), testing both in Windowed and full screen

No success.

There would be a lot more processing going on when driving than in your static shots. Is the problem worse while driving ?

No, it's the same regardless of the car speed.

- Do you have another current game that puts an equivalent amount of stress on the system as Forza 4 that has a similar issue,

or is the problem only in Forza 4 ?

I only had issues with Forza Horizon 4. Forza Motorsport 7 and Dead or Alive 6 (for example) don't present problems (at least apparently).

- Gpu and cpu temps are good (GPU-z also has a cpu temp sensor now) ?  - GPU-Z Video card GPU Information Utility

Both temperature and usage are ok, and I don't have any framedrops. If you watched the video, you might realize there were visual framedrops in game, but this is a issue with the recording itself: during the game, everything is smooth.

- Have you tried the Windows Insider Program forum (Categories at top of this page) ? Someone there may have more

details regarding issues with the 1903 update ?

I've tried the Gaming on Insider Preview forum, but my topic was moved to this very place.

- Nvidia 430 driver ? I see 425.31 . Released 11 April. The driver Nvidia release after the general release of Win10 v1903 may

have any fixes necessary for issues introduced by 1903 ? I'm still using 419.35, but I always update the driver after doing a version update.

Please note that 430.00 is for Windows 1903.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Yes, it's a mystery. If the problem is only with the one game I wouldn't think the 1903 update would be the source of the issue

as the updates don't target specific games, or graphics features, and a corrupted update install would affect all games.

The pixelation in the pink area is often an indication of a hardware issue, but that's not likely in this instance.

But hey! we're talking computers, so maybe the update has 'discovered' (or delivered) an issue that needs to be fixed in the

next Nvidia driver release ? Particularly if you are using the new 2000 series. They do generally have a couple of game specific fixes

in new driver releases.

Have you tried  resetting the game ? Resetting doesn't look too user friendly tough 'This App Will Be Reinstalled'.

I was expecting more of a 'verify files' repair tool such as Steam, and the others use.

-  60fps with around 73% max gpu use. What model Nvidia gpu are you using ? Is the gpu use higher than the cpu use ?

Have you tried disabling V-sync or Anti-aliasing ? Both have been known to cause flashing in games now and then.

(Mass Effect was flashing badly a while back with AA enabled. I hadn't fired it up in I don't know how long, but I cranked the

AA right up in NVCPL today and it's not a problem any more. Could have been a glitch in the driver back then that only affected ME ? )

Hmm, 430.39 was released on the 23rd, but only showed when I looked again today (24th). Mysterious...


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I can confirm the same.  Definitely not because of stress on the cpu or video card as I'm on a 9900k with a 2080ti playing at 1920x1080.  Haven't really played around yet to see if I could do anything to fix it.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

You've also done an early v1903 update ?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I can confirm the same.  Definitely not because of stress on the cpu or video card as I'm on a 9900k with a 2080ti playing at 1920x1080.  Haven't really played around yet to see if I could do anything to fix it.

Guys, I've just found out what triggers the problem. See first post.

I just hope it's fixed for the RTM....

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 You found it !       ...

Ah ha ! The old overlay trick eh!  Forgot all about that one. All overlays have potential for conflicts from time to time

(Steam, Origin, etc. as well) . The Experience has been known to cause issues in past, and I do often suggest installing only the

main driver and PhysX, but didn't think to this time... Oops!

So much to remember....       

"I just wonder if this topic shouldn't be moved to Gaming on Windows Insider, as it's specific to an insider build (that will eventually be RTM)...."

- Nah!  We're only a couple weeks away from v1903 general release, and it may still be useful on these forums when that happens.

Because it only happens with Nvidia's overlay in this instance I expect Nvidia will need to address the problem in their next driver.

Assuming they have heard about the problem already, or MS have not fixed it on the public release.

You may want to post the issue and fix on the Insider forum as a discussion in case no one there has dealt with it yet though.

- I believe you can mark your own post as an answer (I had one person who did so successfully, but another who couldn't ).

If you cannot mark your OP try pasting your fix into your last post and see if you can mark that.

.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Stay away from 1903, it's terrible for gaming, and it's even more of a resource hog than earlier versions, it appears to have a nice memory leak too....currently it's using 9gb's of ram for no particular reason.

Avoid it like the poorly coded bloated garbage it is.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated December 1, 2020 Views 2,788 Applies to: