Civilization IV game no longer works for Windows 8.1 or Windows 10

I play Civilization IV. It use to work fine with Windows 8.1 then approximately a few days ago it stopped working stating I need to run it as an administrator. I change the settings so I can run it as administrator, but the game will not open.

I then decided it would be a good time to upgrade to Windows 10 and see if that fixes the game. After my upgrade to Windows 10, I have the exact same problem. When I run the Windows troubleshooter it states there is a compatibility issue and recommends Windows Vista Service Pack 2. I try to run it under that and it still will not open the game.

I tried reinstalling the game, but it still does not work. I think some type of Microsoft update in Windows 8.1 and Windows 10 makes this game now unplayable.

 
Question Info

Last updated July 20, 2018 Views 2,312 Applies to:
Answer

You have the disk version ?

If so, yes it's now unplayable because of the protection drivers used.

Games from these years, 2000 and later, use Safedisk, Securom, Tages, Macrovision (secdrv.sys). These drivers are declared dangerous by Microsoft and rejected by W10.

You have the original disk ? Well, it's considered a copy now !

No solution for the moment except to run a dual-boot with XP or Seven. Or to use a NoCd crack.

Funny, isn't it ?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.