Windows 10: Error 1303/Warning 1909: Can't Install Programs That Affect Start Menu?

Hi everyone,

I have an extremely frustrating problem in Windows 10. I'd like to install 3ds Max 2016 and a new Kodak app so I get at the pictures on my new phone. However, when installing 3ds I get a warning 1909 error stating that I do not have correct permissions to modify the start menu, basically, even though there is only one account on this PC and it has admin. The same issue happens with this Kodak app and again, I cannot add a shortcut to the start menu so it just gives up on the installation altogether. 

I have tried a great many things to get this working, and you'll notice that these are the "fixes" you'll usually find on Microsoft. None of these have had any effect:

1) Taking permission of my entire C:\ProgramData directory. 

2) Modifying it's security to remove the "read only" attribute. This doesn't work, and if you re-open the properties you'll see it was immediately set back to read-only. I have tried this on the individual start menu folder and all of the rest; it just resets. 

3) Changing permissions to allow every user full access to the directory. 

4) Creating a new administrator account to try installing - same errors. 

5) Turning off inheritance rules and sharing with full access. 

6) Installing as administrator, of course.

7) Giving regular users special permissions over ProgramData to allow full control. 

8) One fix people have been suggesting on other forums is disabling read-only and hitting "retry" in the installer. This has no effect, the permissions are clearly either re-written immediately or my changes are being ignored without an error message. 

This is really, really frustrating. I can't work on a book cover project right now and I can't get my pics of my recent camping trip off of my phone. Can't install any Adobe Creative Suite applications at all. 

 

Question Info


Last updated March 21, 2019 Views 3,661 Applies to:
Answer

I found a fix... Though it indicates a deeper problem with privileges Win 10 assigned to various ProgramData directories.  This was a really frustrating problem and meant that I had to switch to a 3d modeling program I'm unfamiliar with to do some work. I hope my description of the fix helps some people out and points the way to a patch. 

I tried to install Gamevox earlier and received a similar message to the ones before: "The installer has insufficient privileges to access this directory: C:\ProgramData\Microsoft\Start Menu\Programs\Gamevox. The installation cannot continue. Log on as administrator or contact your system administrator.". However, with this installation there was the option to retry without exiting the installer.  

This time I decided that instead of checking the security settings of my Start Menu directory, I would look at specifically the "programs" folder. Two problems were there:

1) The folder, and presumably it's inheritors, was read-only. 

2) In it's security settings, there was only an administrator group. So I manually added "Users" for basic Windows user accounts. I think that's what did the trick. 

So there are actually two things odd about that. This is a fresh installation of Windows 10 not a month or two old on a fresh SSD, first time with anything on it, and only for Windows. So for some reason permissions to this folder either weren't properly assigned, or were somehow changed by some process. 

***SO FOR PEOPLE WITH THIS PROBLEM, BELOW IS THE FIX***

1) Open up Windows Explorer, and navigate to the root directory of whatever drive you have Windows installed on, generally C:. 

2) The directory you want to access is hidden by default. Hit "alt" and it will highlight some tabs at the top of Windows Explorer. Click "view". In the options pane that appears, there will be a place where you can checkmark "hidden items" to display hidden files and folders. Click this. Alternatively, if you are using pre-Windows 10, there will be a "folder options" screen you can access in a similar way that has a list with similar options. 

3) Now a folder called ProgramData will be visible. You're going to go into that directory. Navigate to: (root letter):\ProgramData\Microsoft\Start Menu\

4) There will be a folder called "Programs" right-click that, and go to properties. 

5) In here, there will be some basic folder options, but head over to the security tab at the top. 

6) Dude, where are all my users? Under "group or user names" there'll be an "Add..." option. Click that. It probably just has the current user in there, if you have the same issue I had. 

7) A new window pops up when you click add. What you're going to do is enter "Users" on that third box where it says "Enter the object names". Then click "Check Names" on the right, and it'll enter it as something like "(yourPCname)\Users". Hit ok. 

8) Try that installation again. This is the only fix that worked for me. 

Deepak, could you please mark this as the fix? I can't mark my own as the answer, haha. 

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.