Windows 10 Maps App sometimes does not show the streets or roads on the Map

Affected Apps Windows 10 Maps App
Affected devices Some Windows 10 Desktop devices with NVIDIA processors or intel processors
Issue Maps App launches but the users do not see the roads or streets on the Map
Workaround Workaround only works for Desktop devices with NVIDIA processors. Open NVIDIA Control Panel, select Manage 3D settings. Update the Preferred Graphics Processor to “High-performance NVIDIA processor” (detailed instructions below, if needed). For other devices, unfortunately there is no known workaround. We are working hard to get the fix to your device as soon as possible.

Affected App:

Default Maps app on Windows 10

Issue:

Some devices with NVIDIA processors might not see all the roads when zoomed in on a map. Here’s an example:

It should look like this:

Workaround:

This workaround works only for PCs with NVIDIA processors, we are working on a fix for other devices.

While we are working on getting a fix out as soon as possible, we want to provide a workaround so you can use the Windows Maps app right away.

Please follow these steps:

  1. Go to Start > Settings

  2. In Settings, enter “NVIDIA” in the Search box and press Enter.

  3. Select NVIDIA Control Panel.

  4. Select Manage 3D Settings.

  5. Update the Preferred Graphics Processor to “High-performance NVIDIA processor” and then close the NVIDIA Control Panel.

  6. Close and re-open the Maps app.

  7. You should now see the expected streets visible in the Maps app.

If you prefer not to change this setting for all of your apps and would like more control, follow these steps:

  1. Go to Start > Settings

  2. In Settings, enter “NVIDIA” in the Search box and press Enter.

  3. Select NVIDIA Control Panel.

  4. Select Manage 3D Settings.

  5. Select the Program Settings tab.

  6. Select Add.

  7. Browse to the Windows Maps app in C:\Program Files\WindowsApps\Microsoft.WindowsMaps_4.1511.3161.0_x64__8wekyb3d8bbwe   (this folder name could be different depending on the app version installed on your PC)

  8. Select Maps.Windows.

  9. Set the preferred graphics processor for this app to High performance NVIDIA Processor.

  10. Close and re-open the Maps app.

  11. You should now see the expected streets visible in the Maps app.

 

Update 1/8/16: We’ve been working on a fix, but the problem turned out to be a bit more complex than we’d anticipated. If you install the unverified driver, roads become visible again, but the driver causes other rendering issues in the Maps app. We are working hard on solving the overall issue as soon as possible. We understand that this has been a major inconvenience and we sincerely apologize. We can assure you that this is a top priority for our team.

Update 3/23/16: The Windows and Maps team worked with Intel to fix issues that were impacting systems with 6th generation Intel® Core™ processors (formerly SkyLake). The fix is in the latest Skylake display adapter driver which may be found on Windows Update, Intel Support downloads, or your OEMs support site. This should fix the issues with rendering Maps or showing roads on the map. For Surface Pro 4 or Surface Book the updated drivers were released on February 17th (display driver version 20.19.15.4364). Thanks to everyone for reporting the issue and for the patience while it was resolved. Definitely let us know if you notice any other rendering issues.

 

Discussion Info


Last updated August 7, 2019 Views 9,553 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Thank you for this information!  

I unfortunately have Intel's Integrated Graphics 520 on my Surface Pro 4, but know of others that have Surface Books with the NVidia Graphics cards that can use this information.

For Surface Pro 4 users, this is a universal problem that has been documented since its launch date 30 days ago on October 26th.  Without a built-in cell phone antenna and a realistic 6 hour battery life (not 9 hrs as advertised), it is imperative to use offline maps and roads view (not aerial/satellite view due to battery drain) when using the Maps app while working in the field on a SP4 device.

In my estimation, this issue has not been voiced by Microsoft customers in large numbers because people have moved on to other mapping apps on their cell phones. 

How could this issue not have been fleshed out through Beta testing?

Is there any anticipated date for this issue to come through on an update?

Thanks!

Thank you

I have this issue, waiting for the solution in the coming weeks.

Hi btreece

Thank you for sharing your concerns.

We have received feedback on "roads not visible on map" issue via the Windows Feedback app. I can assure you that we are trying our best to get the fix out as soon as possible. 

Rohan

ATTENTION: To all Surface Book users, there is a fix to roads not showing in the map app. Thank you to Rohan for giving us the most comprehensive and speedy solution to roads not showing on Maps.
Devin Henderson

Thanks for the help on this.  But FYI, on my Book (16/512/dGPU), changing the default setting works, but setting the program option doesn't - it's recorded in the NVidia control panel as being set, but makes no difference :-(

But thanks anyway!  Hope they can fix the issue so we can use maps in tablet-only mode as well.

Chris

The same problem with Intel HD Graphics 530 chip. What you can do to resolve problem temporarily is to got to Device manager and change display adapter to Basic Display Adapter. Relaunch the app - you should see the roads now.

Also affected is the 515 graphics adapter in the Surface Pro 4 m3.

I, too, am looking forward to a quick fix.

We just got the surface 4 and this is my first exposure to Maps.  I will now forget about it and get Google maps.

So far, NOT a good out-of-the-box experience.

Hello Microsoft,

it is quite harsh, that we have to wait so long for a bugfix.

I recently bought Surface Pro 4 with i5 processor. Do not see roads whether using offline maps or not. Really bad out of box experience for a premium product with premium price. :(. Please provide a quick fix.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.