Class not Registered error for pictures with Windows 10

I just upgraded to Windows 10 and I can't access my pictures now, I get a Class not Registered message

**Post moved by the moderator to the appropriate category**


My solution to a similar problem on a new Windows 10 PC...

PROBLEM: Class not Registered error when trying to open a .jpg file.

STEPS TRIED: 1. START-->SETTINGS-->SYSTEM-->Default Apps-->"Reset to Microsoft recommended". 2. SFC scan didn't find any problems. 3. Clean boot didn't help. 4. System Restore to a time when I know things were working didn't help.

The problem remained. Right clicking on the file and selecting OPEN WITH listed PAINT and TWINUI. Paint could open the file, but TWINUI always gave the error. The extended OPEN WITH menu did not list PHOTOS anywhere.

SOLUTION: I pressed START-->ALL APPS-->PHOTOS. Once the program opened once, some setting somewhere got fixed and double clicking on a jpg file worked again. The OPEN WITH menu changed to have PAINT and PHOTOS as the first two options. TWINUI does not appear in the list anymore.

232 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.


Question Info

Last updated September 30, 2020 Views 42,979 Applies to: